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Chapter 1 -  Introduction 
 

Overview 

This manual describes how OpenFTA is used for the drawing and analysis of fault trees. It includes a 
step-by-step tutorial and a reference section describing each of the tool’s facilities. 

What is OpenFTA? 

OpenFTA is a sophisticated engineering tool for drawing, analysing and printing fault trees. The task of 
the analyst is aided by the tool’s many facilities and features, which include: 

• a point-and-click graphical user interface enabling rapid drawing of fault trees 

• support for the full set of fault tree symbols in accordance with NUREG-0492 

• a database for storing primary event definitions 

• qualitative analysis of fault trees to determine minimal cut sets 

• quantitative analysis of fault trees (including a Monte Carlo Simulation facility). 

Pre-Requisites 

This manual assumes that the user is familiar with modern software packages that have graphical user 
interfaces (GUIs). 

This manual is not intended to be a textbook on fault tree analysis. It is assumed that the user is familiar 
with the methodologies involved in the drawing and analysis of fault trees and the terminology 
employed in the discipline. 

This Manual 

This manual is divided into two main sections: 

• the OpenFTA Tutorial introduces the facilities offered by OpenFTA by working through the 
process of drawing and analysing a fault  tree 

• the OpenFTA Reference provides a comprehensive description of each of the facilities and 
functions provided by OpenFTA. 

 

Throughout the document, when a new term is introduced in the text, it is highlighted in a bold font. 
Text that is in an italic font is text that is displayed by the OpenFTA user interface. 
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Chapter 2 -  OpenFTA Tutorial 
 

Overview 

This chapter introduces key concepts and provides a guide to the facilities offered by OpenFTA. For 
more detailed information on any particular facility of OpenFTA, refer to Chapter 3. 

This tutorial describes: 

• how to start OpenFTA 

• getting on-line help from OpenFTA 

• how to create and modify fault tree drawings 

• how to specify primary event definitions 

• how to analyse fault trees 

• exporting data to other packages. 

Starting OpenFTA 

OpenFTA is started by selecting OpenFTA from the windows “Start” menu. The default location for 
this is inside a group called “Formal Software Construction -> OpenFTA” 

 

Figure 1: OpenFTA’s Initial Display. 
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Figure 1 shows the windows displayed when OpenFTA is first started i.e. OpenFTA and OpenPED. 
The OpenFTA window and the OpenPED window provide facilities for constructing fault trees and are 
discussed in more detail in the following sections. 

The OpenFTA window consists of the following four elements: 

 

 

 

 

 

 

 

 

Figure 2: Components of the OpenFTA window. 

The menubar consists of a number of menus of options that can be applied to the fault tree being 
drawn.  

The toolbar consists of shortcuts (in the form of icon buttons) to frequently used menu options.  

When the mouse cursor is placed over an icon button, a small description (a Tool Tip) is displayed to 
provide a hint about the function of the button. Tool tips are also provided on the controls of dialog 
boxes. 

Many frequently used menu options also have accelerators  and mnemonics . 

The symbol palette on the left of the OpenFTA window presents the drawable elements of a fault tree. 
If any symbol is not permitted (e.g. AND gate if a gate is selected on the canvas area), the symbol 
button is greyed-out. Thus, only syntactically valid fault trees can be drawn using OpenFTA. 

The canvas area of OpenFTA is a scrollable area on which a fault tree is drawn. Note that only one tree 
may be drawn at a time. The top-level intermediate event of the fault tree is always present at the top 
centre of the canvas, with all child symbols laid out automatically by OpenFTA. This ensures that the 
fault tree is laid out in an efficient and aesthetic manner. 

The OpenPED window allows access to the primary events database capability of OpenFTA. The 
provision of a separate capability to handle the management of primary events allows fault trees to be 
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constructed with emphasis on how the system decomposes without knowledge of the details behind the 
primary events. 

The OpenPED window will be discussed in more detail later in this chapter. 

Getting Help 

OpenFTA assists the user by providing help screens. Overall help for OpenFTA is available under the 
Help menu option. Context sensitive help is available from the Help buttons on the dialogs. Tool tips 
are also provided on menu options and dialog controls. 

To display help on a particular topic, select Help->Index to popup the help index list, and click on any 
item to display its help screen. 

Drawing A Fault Tree 

The basic mode of operation when drawing a fault tree with OpenFTA is to select a parent symbol on 
the canvas, then select a control to manipulate that symbol. The insertion of fault tree symbols is 
achieved by such a mechanism. Selecting one of the available symbols from the symbol palette inserts 
that symbol below the selected symbol. As usual, if any symbol is inapplicable, it is greyed out. 

As the fault tree is extended, it may become too large to be viewed on the canvas. Hidden areas of the 
fault tree can be viewed by using the scrollbars to navigate around, or by selecting the View->Tree 
Overview option. This presents a resizeable window, which contains a scaled version of the fault tree. 
Selecting a symbol within the overview causes the corresponding symbol of the fault tree to be selected 
and centred on the main canvas area. Thus large trees can be easily navigated. 

When drawing a fault tree, mistakes will be made, or changes will be required from time to time. 
OpenFTA supports standard editing operations and some application specific ones. 

Any symbol on a fault tree can be viewed as the parent of a sub-tree, even a symbol on its own. Thus, 
as a fault tree is made up of smaller sub-trees, the smaller trees can be cut, copied and pasted to other 
parts of the fault tree drawing. Obviously, there are some restrictions (e.g. the top level intermediate 
event cannot be cut from the drawing), but OpenFTA provides warnings to prevent the tree becoming 
syntactically invalid and an Undo option that can revert a tree to a previous state. 

In addition, OpenFTA allows some manipulation of the fault tree for aesthetic reasons. It is possible to 
change the order in which symbols are drawn below their parents (with Edit->Shift Left  and Edit->Shift 
Right). This has no impact on the analysis of the tree, only on how it is displayed. 

As symbols are added, they can be annotated. All symbols can be given an ID, as well as other 
information according to their type. To enter the annotations (for all but the primary events) multi-click 
the left mouse button with the cursor anywhere within the boundary of a symbol. This causes the 
symbol to become selected and displays an associated dialog. The descriptive text entered may be 
longer than that which can be displayed within a symbol's boundary. In this case, the text is truncated 
and ended with a continuation indicator (...) to show that more text exists. 



Chapter 2 - OpenFTA Tutorial 

 
OpenFTA Version 1.0 User Manual 

 
© Copyright 2005 Formal Software Construction Ltd 

 
 

8 

Primary event IDs and details are entered in a different manner, consistent with their characteristics 
within OpenFTA. Multi-clicking on a primary event symbol does not popup a dialog, but selects the 
primary event in the database. This will be described later in this chapter. 

If the cursor falls outside the boundary of any symbol, a dialog allowing free format descriptive text for 
the whole tree is displayed. This text is always displayed in the top left of the canvas area and on any 
hardcopy of the tree. 

The gate dialog provides the ability to change a gate's type if necessary. 

Preferences 

The preferences dialog allows the colours of the FTA canvas to be specified. This can be invoked by 
selecting Edit->Preferences.... 

 

 

 

 

 

 

Figure 3: OpenFTA preferences dialog. 

The two radio buttons switch the canvas between colour and monochrome views. Clicking on any of 
the symbol or colour buttons launches a selection dialog that changes the colour of the selected item. 

Clicking the OK button applies the changes and closes the dialog. Clicking the Cancel button aborts the 
changes and closes the dialog. Clicking the Defaults button reverts back to the original colours set 
when OpenFTA was first installed. Clicking the Help button brings up the context sensitive help for the 
preferences dialog. 

File Storage 

Fault trees can be saved or opened from the File menu (or via the toolbar). The File operations provide 
a degree of protection e.g. from destroying unsaved trees by opening an existing tree. All fault trees are 
stored in files with the extension .fta. When using the file selection dialog to access fault trees, the 
.fta extension may be omitted from the selection field. 
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Figure 4: File Selection Dialog. 

Printing 

Fault trees can be printed to any printer (via File->Print). The destination printer and the details of the 
required paper size and orientation can be changed by selecting the File->Printer Setup... and File-
>Page Setup... menu items. 

 

Figure 5: Print and Page Setup Dialogs. 

It is possible to print fault trees over multiple pages. Choosing File->Print Preview... launches the Print 
Preview dialog. This allows the number of pages, both horizontally and vertically, to be specified. The 
toolbar provides access to the Printer and Page Setup dialogs along with a button to print the tree. 
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Figure 6: Print Preview Dialog.  

Providing Primary Event Information 

To complete the drawing of a fault tree, information on the primary events within the tree must be 
supplied. This is achieved either by retrieving the events from an existing primary events database or 
by creating a new database. 

Databases are accessed through the OpenPED window. This window has a menubar and toolbar akin to 
those found on the OpenFTA window, a scrolled list of the primary events within the open database 
and the details of the selected primary event. 

Separating the primary events from the fault tree drawing allows many benefits, including the 
partitioning of work and allowing multiple trees to share a single database. It decouples the process of 
producing a fault tree for a system from the mechanics of describing the individual events that 
influence the system.  

This separation also allows a single primary event to appear in a tree, or in many trees, without the 
need to duplicate the primary event details for every occurrence. Primary event details can exist in a 
database without appearing in a tree.  
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Figure 7:  OpenPED Window.  

Adding an event to a database requires a minimum amount of information for that event. Every event 
must have a unique ID within the primary events database, it must have a probability of failure and it 
must have a type. In practice, the events will include a textual description to distinguish them, or 
provide further information. 

The probabilities are applied by one of two models, probability model (P-model) or lambda-model 
(? -model). The P-model is used to state the probability of a primary event failing as an absolute value. 
The ?-model is used to state the probability that a primary event will fail within a unit time period i.e. 
as a function of time. Each event’s probability can be set according to the model that is appropriate. See 
Appendix A for more details. 

An event is added to the database by filling in the minimum information in the details area of the 
OpenPED window and pressing Apply. If the information supplied is valid, the event ID is added to the 
list of events in the database. 

An event may be modified by selecting it in the Primary Events list (which causes its details to be 
displayed), modifying the required information and selecting Apply. If the details are invalid, the 
database is unaffected and if the changes cannot be corrected or should be discarded, Clear can be 
pressed. 

The OpenPED window provides similar File options to the OpenFTA window. 
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Connecting Trees With Databases 

When a primary events databas e has been saved, it can be associated with the fault tree. This is 
performed by selecting the File->Database option on the OpenFTA window. Note that a fault tree may 
be associated with only one database. 

Opening a saved fault tree automatically opens the associated primary events database in the OpenPED 
window. 

Associating a database with a fault tree is only the first step in preparing the fault tree for analysis. 
Every primary event symbol on the fault tree must be linked to a primary event definition in the 
database. This is performed by selecting a primary event on the tree, selecting the required primary 
event in the primary events database and selecting Edit->Link  (or the corresponding toolbar icon) on 
the OpenFTA window. The tree will now display the event ID next to the symbol, together with its 
probability and any descriptive text within the symbol. 

Validation 

Once the fault tree is considered complete, it can be validated. Validation ensures that the tree is 
syntactically and semantically correct (e.g. all events have been linked to valid, defined primary 
events). A fault tree is validated by selecting Analysis->Validate which produces an on-screen report. 
This report will list all the errors  that prevent the tree being considered valid, together with any 
warnings. The most common error is that an event is not found in a database, either because the link 
has never been made between the tree event and the database event, because the linked primary event 
has been deleted from the primary events database, or because the incorrect database has been 
associated with the tree. 

Analysing The Fault Tree 

When a fault tree is valid, a full analysis of the fault tree can be performed. With OpenFTA this can be 
performed in two ways. A deterministic analysis may be achieved by a qualitative analysis to generate 
minimal cut sets . This enables a quantitative evaluation to be performed (on a logically reduced tree 
represented by the minimal cut sets). Alternatively a statistical  analysis may be performed using the 
Monte Carlo Simulation facility. OpenFTA implements an algebraic generation of minimal cut sets 
which is very quick for most developed trees. Minimal cut set generation is performed by selecting 
Analysis->Minimal Cut Sets....  

Pressing OK on the resulting dialog displays a report file associated with the fault tree, which is valid 
until the tree is next edited. The report contains a list of all the minimal cut sets identified for the tree. 
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Figure 8: Minimal Cut Set Generation Dialog. 

When minimal cut sets for a tree have been generated, the quantitative analysis of the tree is performed 
by selecting Analysis->Numerical Probability... This displays the numerical probabilities dialog. 

 

Figure 9: Numerical Probabilities Dialog. 

Pressing OK on the dialog displays a report file associated with the fault tree, which is valid until the 
tree is next edited. The report contains the calculated probability of the top level event occurring, 
together with the probabilities for each of the minimal cut sets occurring and the contribution that each 
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of the primary events makes to the top level failure. The top-level event calculation uses the 
appropriate P-model or ?-model according to how each primary event probability is defined. 

The Monte Carlo Simulation allows a statistical determination of the cut sets for a tree and an 
approximation of the system failure by randomly failing events and determining the probability of 
overall system failure. 

The Monte Carlo Simulation provides a statistical approximation and, although it does not guarantee 
that all minimal cut sets will be found, the likelihood is that the approximation will be adequate for 
very large trees for which even the algebraic generation of cut sets is too time consuming. The report 
generated gives statistical information on the accuracy of the result. The more simulations run at a time, 
the more accurate the result will be, but at the expense of processing time. 

The Monte Carlo Simulation analysis of the tree is performed by selecting Analysis->Monte Carlo 
Simulation.... 

 

 

 

 

 

 

Figure 10: Monte Carlo Dialog. 

Pressing OK on the resulting dialog displays a report file associated with the fault tree, which is valid 
until the tree is next edited. 

At any later time reports can be viewed and printed. This is achieved through the options of the Report 
menu. 

Decomposing Fault Trees 

The transfer-in facility supports the splitting of large fault trees into more manageable chunks. 
Because each tree transferred in exists as a fault tree in its own right, all of the OpenFTA operations 
including analyses can be applied to that tree individually. Any tree may be transferred into any other 
tree, any number of times. Trees may be broken up to support team working, to reflect redundancy in 
the systems or maybe to defer working on a little known area of a system. 

Transfer-in trees make large trees easier to manage but have no impact on the analysis. Each sub-tree 
can be analysed in isolation, or the analysis may be performed on the top level tree. 
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To include a transferred in tree add a transfer-in symbol at the required position in the tree, and multi-
click on the transfer-in symbol. This displays a dialog to add an ID. This ID is equivalent to a tree name 
(and is displayed on the tree with a .fta extension to reinforce this concept). 

If a sub-tree has been identified as a candidate for converting into a transfer-in tree, the sub-tree can be 
cut or copied, the File-> New option selected and the sub-tree pasted onto the canvas area and saved in 
the normal manner. A transfer-in symbol with the ID of the newly created tree can then be added to the 
original tree. 

If a tree is used as a transfer-in tree, the top level intermediate event may have a transfer-out symbol 
added and annotated, but this is not obligatory. 
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Chapter 3 -  OpenFTA Reference 
 

Overview 

This reference section describes each of the user interface controls provided by OpenFTA. 

For each control, brief descriptions of form and function are followed by an explanation of usage and 
effect. 
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Analysis 

Control Type  
Pulldown Menu 

Function 
Provides access to facilities for analysing fault trees. 

Location 
OpenFTA menubar -> Analysis  

Shortcuts  
Accelerator: None 

Toolbar: None 

Pre-conditions 
None 

Operation 
This menu provides the following options: 

• Validate - determines if the fault tree currently displayed is valid and hence ready for further 
analysis  

• Minimal Cut Sets... - displays a dialog from which minimal cut set generation is initiated 

• Numerical Probability... - displays a dialog from which a deterministic qualitative analysis of 
the fault tree is initiated 

• Monte Carlo Simulation... - displays a dialog from which a statistical analysis of the fault tree 
is initiated. 

Cross References 
Minimal Cut Sets, Monte Carlo Simulation, Numerical Probability and Validate. 
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Apply (OpenPED) 

Control Type  
Push Button 

Function 
Provides a means to accept a new or modified entry into the primary events database. 

Location 
OpenPED -> Apply 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
On activation, the data in the ID, Probability and Description text fields, the Type radio buttons and the 
Constant Failure Rate/Unit Time  and Dormant toggle buttons are validated.  

If the ID is valid and an event with that ID does not already exist in the database, a new entry with the 
supplied data is added to the database and the Primary Events list updated accordingly. 

If the ID is valid and an event with that ID does exist in the database, then if the Type of event has been 
altered, OpenFTA requests confirmation before overwriting the existing database entry with the 
supplied data. 

Cross References 
Clear (OpenPED). 
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Clear (OpenPED) 

Control Type  
Push Button 

Function 
Provides a means to clear the fields in the primary events database window. 

Location 
OpenPED -> Clear 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
On activation, this causes the ID and Description text fields to be cleared, the Type radio buttons to be 
deselected and the Constant Failure Rate/Unit Time  and Dormant toggle buttons to be deselected and 
the probability set to zero. 

Cross References 
Apply (OpenPED). 
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Copy(OpenFTA) 

Control Type  
Menu Option 

Function 
Copies the current selection and the entire sub-tree below it, from the fault tree displayed in the 
OpenFTA window, to the clipboard. 

Location 
OpenFTA menubar -> Edit -> Copy 

Shortcuts  
Accelerator: Ctrl+C. 

Toolbar:   

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
Used to place a copy of the current selection and the sub-tree below it to the clipboard.  

Selections copied to the clipboard are available for the Paste operation. Any information previously 
held on the clipboard is lost when a Copy operation is carried out. 

Cross References 
Cut, Paste and Undo. 



Chapter 3 - OpenFTA Reference 

 
OpenFTA Version 1.0 User Manual 

 
© Copyright 2005 Formal Software Construction Ltd 

 
 

21 

Copy(OpenPED) 

Control Type  
Menu Option 

Function 
Copies the current selected text from the Id, Probability or Description fields to the clipboard. 

Location 
OpenPED menubar -> Edit -> Copy 

Shortcuts  
Accelerator: Ctrl+C. 

Toolbar:   

Pre-conditions  
Text in one of the text fields is selected. 

Operation 
Used to place a copy of the currently selected text from the ID, Probability or Description text fields 
onto the clipboard.  

Selections copied to the clipboard are available for the Paste operation. Any information previously 
held on the clipboard is lost when a Copy operation is carried out. 

Cross References 
Cut and Paste. 
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Constant Failure Rate/Unit Time 

Control Type  
Toggle Button 

Function 
Provides a means to state a primary event’s failure rate in terms of the probability that it will fail within 
a given time period i.e. as a function of time (? -model) rather than as an absolute probability (P-model). 

Location 
OpenPED -> Constant Failure Rate/Unit Time 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
If set, on activation of the Apply button, the probability of the current event will be entered into the 
primary events database as a function of time (? -model), rather than as a function of probability, (P-
model).  

For more details please refer to Appendix B. 

Cross References 
Apply (OpenPED), Monte Carlo Simulation and Numerical Probability. 
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Cut (OpenFTA) 

Control Type  
Menu Option 

Function 
Removes the current selection and sub-tree below it, from the fault tree displayed in the OpenFTA 
window and copies it to the clipboard. 

Location 
OpenFTA menubar -> Edit -> Cut 

Shortcuts  
Accelerator: Ctrl+X. 

Toolbar: 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
Used to remove the current selection and sub-tree below it from the displayed fault tree and copies it to 
the clipboard.  

Selections copied to the clipboard are available for the Paste operation. Any information previously 
held on the clipboard is lost when a Cut operation is carried out. 

Cross References 
Copy, Paste and Undo. 
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Cut (OpenPED) 

Control Type  
Menu Option 

Function 
Removes the current selected text from the ID, Probability or Description fields and copies it to the 
clipboard. 

Location 
OpenPED menubar -> Edit -> Cut 

Shortcuts  
Accelerator: Ctrl+X. 

Toolbar: 

Pre-conditions  
Text is selected in one of the text fields. 

Operation 
Removes the current selected text from the ID, Probability or Description fields and copies it to the 
clipboard.  

 
Selections copied to the clipboard are available for the Paste operation. Any information previously 
held on the clipboard is lost when a Cut operation is carried out. 

Cross References 
Copy and Paste. 
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Database 

Control Type  
Menu Option 

Function 
Creates an association between a fault tree and a primary events database. 

Location 
OpenFTA menubar -> File -> Database 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
The fault tree and primary events database have been saved. 

Operation 
Associate the events database displayed in the OpenPED window with that currently displayed on the 
OpenFTA canvas. Any existing association between a tree and a database is overridden. 

As a consequence of forming an association between a tree and a database, the data displayed in the 
tree’s primary events will be updated to be consistent with the database i.e. each primary event will 
display the description and probability corresponding to the event’s ID. 

Cross References 
Link. 
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Delete (OpenFTA) 

Control Type  
Menu Option 

Function 
Removes the current selection and sub-tree below it, from the fault tree displayed in the OpenFTA 
window. 

Location 
OpenFTA menubar -> Edit -> Delete 

Shortcuts  
Accelerator: Ctrl+D. 

Toolbar: 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
Used to remove the current selection and sub-tree below it, from the displayed fault tree. Unlike Cut, 
the deleted sub-tree is not placed on the clipboard. 

Cross References 
Cut, Undo. 
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Delete Event (OpenPED) 

Control Type  
Menu Option 

Function 
Removes the currently selected primary event from the primary events database displayed in the 
OpenPED window. 

Location 
OpenPED menubar -> Edit -> Delete 

Shortcuts  
Accelerator: Ctrl+D. 

Toolbar: 

Pre-conditions  
An item in the Primary Events list is selected. 

Operation 
Used to remove the currently selected primary event from the database. Confirmation is requested 
before this action is completed since no Undo operation is available. 

Cross References 
None. 
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Dormant 

Control Type  
Check Box 

Function 
Provides a means to depict a primary event as being dormant. 

Location 
OpenPED -> Dormant 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
If set, on activation of the Apply button, the current event will be entered into the primary events 
database as a dormant event. 

Dormant events are special case primary events. They may fail with no visible external effects. An 
example is the failure of a filament in a warning lamp - if the light is not on, then it would normally be 
assumed that the system which it is monitoring does not require a warning to be issued. However, it 
could be that both the lamp filament and the subsystem it monitors have failed. 

In OpenFTA, the dormant event is treated the same as any other primary event, with the exception that 
the symbol on the canvas is drawn with a double line. 

Cross References 
None. 
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Edit (OpenFTA) 

Control Type  
Pulldown Menu 

Function 
Provides access to facilities for manipulation and alteration of the currently displayed fault tree. 

Location 
OpenFTA menubar -> Edit 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to invoke the operations that alter the fault tree displayed on the main OpenFTA canvas area. 

Cross References 
Copy  (OpenFTA), Cut  (OpenFTA), Delete (OpenFTA), Link, Paste  (OpenFTA), Preferences..., 
Selected..., Shift Left, Shift Right and Undo. 
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Edit (OpenPED) 

Control Type  
Pulldown Menu 

Function 
Allows access to the facilities for editing the primary events database. 

Location 
OpenPED menubar -> Edit 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
This menu is used to access the Cut, Copy and Paste operations used to manipulate data between the 
ID, Probability and Description  fields. It also provides the facility to Delete Primary Events from the 
Primary Event Database. 

Cross References 
Copy (OpenPED), Cut (OpenPED), Delete (OpenPED) and Paste (OpenPED). 
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Exit 

Control Type  
Menu Option 

Function 
Shuts down OpenFTA. 

Location 
OpenFTA menubar -> File -> Exit 

Shortcuts  
Accelerator: Ctrl+Q. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to terminate the OpenFTA application.  

If neither the primary events database nor the fault tree have been modified without saving, then the 
execution of the application is terminated and OpenFTA is removed from the display. 

If the fault tree has been modified and not saved, then confirmation is requested before OpenFTA 
proceeds with the termination of the application. 

If the database has been modified and not saved then the operator is informed and the operation is 
aborted. 

Cross References 
Save (OpenFTA), Save (OpenPED), Save As... (OpenFTA) and Save As... (OpenPED). 
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Export Image... 

Control Type  
Menu Option 

Function 
Exports the OpenFTA canvas as a JPEG image. 

Location 
OpenFTA menubar -> File -> Export Image... 

Shortcuts  
Accelerator: Ctrl+E 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Exports the OpenFTA canvas as a JPEG image. A file selection dialog is posted, allowing the target 
file to be specified.  

Cross References 
None. 
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Export Text File... 

Control Type  
Menu Option 

Function 
Exports the OpenPED database as a text file. 

Location 
OpenPED menubar -> File -> Export Text File... 

Shortcuts  
Accelerator: Ctrl+E 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Exports the OpenPED database as a text file. A file selection dialog is posted, allowing the target file to 
be specified.  

Cross References 
None. 
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File (OpenFTA) 

Control Type  
Pulldown Menu 

Function 
Provides access to facilities for manipulating fault tree files. 

Location 
OpenFTA menubar -> File 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to invoke the following operations; New, Open..., Save, Save As..., Export Image..., Printer 
Setup..., Page Setup..., Print Preview..., Print..., Database and Exit. 

Cross References 
Database, Exit, Export Image..., New (OpenFTA), Open (OpenFTA), Page Setup..., Page Setup Dialog, 
Print (OpenFTA), Print Dialog, Print Preview..., Printer Setup..., Save (OpenFTA) and Save As 
(OpenFTA). 
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File (OpenPED) 

Control Type  
Pulldown Menu 

Function 
Provides access to facilities for manipulating primary events databases. 

Location 
OpenPED menubar -> File 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to invoke the following operations; New, Open..., Save, Save As..., Export Text File... , Printer 
Setup..., Page Setup... and Print.... 

Cross References 
Export Text File..., New (OpenPED), Open (OpenPED), Page Setup..., Page Setup Dialog, Print 
(OpenPED), Print Dialog, Printer Setup..., Save (OpenPED) and Save As (OpenPED). 
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File Selection Dialog 

Control Type  
Dialog 

Function 
Provides a means to open or store a file. 

Location 
Invoked for all File operations. 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
The dialog consists of: 

• a Files of Type drop down list: this shows the filter currently in use. A filter is a way of limiting 
the types of files displayed in the dialog. The default filter is currently displayed which means 
that only files with the specified extension will be displayed in the dialog.  

• a scrollable list of Directories and Files: lists the files and directories below the current working 
directory. Movement between directories is performed by multi-clicking on any directory in the 
list.  

• a File name  text field: contains the filename of the currently selected file. 
 

File selection takes place by either: 

• multi-clicking on the required file 

• selecting the file and activating the Open/Save button 

• completing the selection text field and activating the Open/Save button. 
 

On activation of the Open/Save button, the required file operation is attempted and if successful the 
dialog is removed from the screen. 

On activation of the Cancel button, the file operation is aborted and the dialog is removed from the 
screen. 

Cross References 
None. 
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Help 

Control Type  
Pulldown Menu 

Function 
Provides access to the online help facility. 

Location 
OpenFTA and OpenPED menubars -> Help 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to access information on any aspect of the OpenFTA application. The categories of help provided 
are; Help on Help, Index..., User Support and Copyright. 

The Help on Help option provides information on the help facility. 

The Index... option opens a scrollable window which contains a list of all the help topics available. By 
selecting one and pressing the Ok button the information on that subject is displayed. 

The User Support option details how to get technical support. 

The Copyright option displays the version of the application and a copyright notice. 

OpenFTA help is context -sensitive. The help topics may be accessed from within the application’s 
dialogs, by using the Help button, where available. 

Cross References 
None. 
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Link 

Control Type  
Menu Option 

Function 
Connects the currently selected event symbol in the fault tree to the selected primary event in the 
database. 

Location 
OpenFTA menubar -> Edit -> Link 

Shortcuts 
Accelerator: Ctrl+I. 

Toolbar: 

Pre-conditions  
A primary event is selected on the OpenFTA canvas area. The database displayed in the OpenPED 
window is associated with the fault tree depicted on the canvas and an event in the Primary Events list 
is selected. 

Operation 
On activation, the currently selected event in the fault tree is linked to the selected primary event in the 
database. This causes the ID, Probability value and Description for the selected fault tree event symbol 
to be displayed on the canvas.  

If the Type of event in the database differs from that of the selected event in the tree, then confirmation 
is requested before the action is completed. On completion the symbol on the canvas is changed to the 
type held within the database. 

Note that a Link  operation cannot be undone using the Undo option. 

Cross References 
Database. 
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Minimal Cut Sets... 

Control Type  
Menu Option 

Function 
Calculates the minimal cut sets for the currently displayed fault tree. 

Location 
OpenFTA menubar -> Analysis -> Minima l Cut Sets... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
The fault tree has been saved and is logically valid. 

Operation 
This menu option is used to initiate the generation of the minimal cut sets for a fault tree.  

When invoked, a minimal cut sets dialog with the title OpenFTA: Minimal Cut Sets is presented. This 
dialog is used to specify whether or not to use the minimal cut sets already on file and to specify which 
orders of minimal cut sets should be generated. 

If a minimal cut sets file already exists then the Use minimal cut sets on file toggle button is selected 
and the directory path to the minimal cut sets file is displayed, as well as the number and order of the 
available minimal cut sets. 

If the Generate all minimal cut sets toggle button is selected, all orders of minimal cut sets for the fault 
tree will be calculated. If the Limit minimal cut set order to toggle button is selected, only minimal cut 
sets up to a specific order will be generated. The required maximum cut set order is specified using the 
stepper (the two, back-to-back arrows). 
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Figure 11: Minimal Cut Sets Dialog. 

On activation of the OK  button, OpenFTA displays a working dialog and carries out the minimal cut set 
generation, using the parameters requested. The Stop button on the working dialog may be pressed to 
abort the generation of the minimal cut sets. 

Note that the generation of minimal cut sets may take a long time for very large trees, when large order 
minimal cut sets are required. 

On activation of the Cancel button, the operation is aborted and the dialog is removed. 

On activation of the Help button, context sensitive help information is displayed. 

On completion of the operation, a Qualitative Report is generated (to a file named: <fault tree 
name>.mcs) and displayed in a dialog. The report consists of: 

• the directory path to the file used to store the fault tree analysed in this report  

• the date and time of the report’s creation 

• the method used to calculate the minimal cut sets  

• the number of unique primary events in the fault tree, including those in any transfer trees 

• the range of cut set orders possible for the fault tree 

• a list of the minimal cut sets separated into the orders that have been located 

• a table titled Qualitative Importance Analysis. The table represents the distribution of the 
number of minimal cut sets found per order of cut sets that are possible for the fault tree. 

Cross References 
Analysis, Print (OpenFTA, Report), Report, Validate and View (OpenFTA, Report). 
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Monte Carlo Simulation... 

Control Type  
Menu Option 

Function 
Calculates the probability of occurrence of the top level event of the displayed fault tree and generates 
(and displays) an associated analysis report. 

Location 
OpenFTA menubar -> Analysis -> Monte Carlo Simulation... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
The fault tree has been saved and is valid. 

Operation 
Determines the probability of the top event occurring by using a Monte Carlo Simulation (statistical) 
algorithm. Also determines (statistically) the cut sets and minimal cut sets, but note that not all cut sets 
may be determined. 

On activation a OpenFTA: Monte Carlo dialog is displayed containing: 

• a statement of the total number of unique primary events in the displayed fault tree (including 
those in any transfer-in trees) 

• a Number of simulations text field. This contains the number of Monte Carlo Simulations that 
will be performed upon the fault tree. A default value will be displayed, but can be altered. 
Since a random number generator is used in this method, if the number of simulations is 
increased, the accuracy of the results obtained will increase, but with the penalty of a longer 
execution time for the calculations 

• a Unit Time  text field. This text field stipulates the number of unit times for which each Monte 
Carlo Simulation run is to simulate. This is only required if there are primary events whose 
probabilities have been entered into the primary events database as a function of time (? -
model), rather than as a function of probability (P-model). A default value will be displayed, 
but can be altered to suit experimental needs. See Appendix B for more details  

• an Estimated run time  statement. This is an estimate of how long the calculation will take, 
depending upon the parameters stipulated in the dialog. 
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Figure 12: Monte Carlo Dialog. 

On activation of the OK  button, a working dialog is displayed and the Monte Carlo Simulation is 
executed. The Stop button on the dialog may be pressed to abort the simulation at any time.  

On activation of the Cancel button, the procedure is aborted and the OpenFTA: Monte Carlo dialog 
removed from the screen. 

On activation of the Help button, context sensitive help information is displayed. 

On completion of the simulation, the OpenFTA: Monte Carlo dialog is removed from the screen, a 
Monte Carlo Report is generated (to a file named: <fault tree name>.mrp) and displayed in a 
dialog. The report consists of: 

• the directory path of the file used to store the fault tree analysed in this report  

• the date and time of the report’s creation 

• the number of unique primary events in the displayed fault tree (including any transfer-in trees) 

• the number of Monte Carlo Simulation runs that have been performed upon the displayed fault 
tree 

• the number of unit times simulated for each run 

• the number of system failures that occurred, (occurrences of the top level event) due to primary 
events being failed during the calculations 

• the probability of at least one component in the tree failing during the simulation 

• the probability of the top level event occurring 

• a table of the cut sets found during the simulations. Each row of the table consists of: the cut 
set, the number of failures attributed to it in the simulations, the estimated probability of one of 
the events in that cut set occurring and the percentage imp ortance of the cut set in comparison 
to the other cut sets found 

• a table titled Compressed. This is the same as the previous table, but those cut sets which are 
less minimal versions of others are subsumed by the more minimalistic ones. The other fields 
such as the estimated probability are adjusted accordingly 

• a table titled Basic Event Analysis. This contains a list of all of the primary events in the fault 
tree and their failure contribution towards the top level event occurring. This contribution is 
also stated as a percentage importance value for each primary event. 

Cross References 
Analysis, Minimal Cut Sets, Print (OpenFTA), Report, Validate and View (OpenFTA, Report). 
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New (OpenFTA) 

Control Type  
Menu Option 

Function 
Provides a blank canvas area for the drawing of a new fault tree in the OpenFTA window. 

Location 
OpenFTA menubar -> File -> New 

Shortcuts  
Accelerator: Ctrl+N. 

Toolbar:  

Pre-conditions  
None. 

Operation 
Used to create a canvas displaying a single empty intermediate top-level event. The application is then 
ready for the drawing of a new fault tree.  

If the fault tree currently on display has been modified and not saved, then confirmation is requested 
before OpenFTA proceeds with the New operation. 

Cross References 
None. 
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New (OpenPED) 

Control Type  
Menu Option 

Function 
Provides an empty primary events database. 

Location 
OpenPED menubar -> File -> New 

Shortcuts  
Accelerator: None. 

Toolbar:  

Pre-conditions  
None. 

Operation 
Used to create an empty primary events database. 

If the database currently on display has been modified and not saved, then confirmation is requested 
before OpenPED proceeds with the New operation. 

Cross References 
None. 
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Numerical Probability... 

Control Type  
Menu Option 

Function 
Calculates the probability of occurrence of the top level event of the displayed fault tree and generates 
(and displays) an associated analysis report. 

Location 
OpenFTA menubar -> Analysis -> Numerical Probability... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
Fault tree has been saved, is valid and the minimal cut sets have been generated. 

Operation 
Calculates the minimal cut set probabilities for the fault tree and the probability of the top level event 
occurring (system failure). 

On activation a OpenFTA: Probabilities dialog is displayed containing: 

• a statement of the total number of unique primary events in the displayed fault tree (including 
those in any transfer-in trees) 

• a text field containing the directory path to the generated minimal cut sets file 

• a description of the file consisting of the number of minimal cut sets, their maximum order and 
the date and time of file generation 

• a Use all minimal cut sets radio button. If this is selected, then all the generated minimal cut 
sets are used in the numerical probabilities calculation 
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Figure 13: Numerical Probabilities Dialog. 

• a Limit minimal cut set order radio button. This is only available if the Use all minimal cut sets 
radio button is not selected. This limits the order of the minimal cut sets used in the calculation 
to the value chosen using the stepper (the two, back-to-back arrows) 

• a Number of terms option which is altered through the use of a stepper. The option is provided 
in order to limit the number of terms used in the probability calculation. This uses a series 
expansion in which there are n terms each with nCr sub terms making a total number of 2n 
possible terms. By limiting the number of terms used, the calculation is speeded up at a cost of 
precision. In practice, the terms used get smaller rapidly and it is rarely necessary to go past the 
third term in the calculations for a large tree. See Appendix B for more details  

• a Unit Time  text field. This text field stipulates unit time for which the numerical probability is 
to be calculated. This is required if there are primary events whose probabilities have been 
entered into the primary events database as a function of time (? -model), rather than as an 
absolute probability, (P-model). A default value will be displayed, but can be altered to suit 
experimental needs. See Appendix B for more details  

• an Estimated run time  statement. This is an estimate of how long the calculation will take, 
depending upon the parameters stipulated in the dialog. 

 

On activation of the OK  button, a working dialog is displayed and the numerical probabilities 
calculation is initiated. The Stop button on the dialog may be pressed to abort the process at any time.  

On activation of the Cancel button, the procedure will be aborted and the OpenFTA: Probabilities 
dialog will be removed from the screen. 

On activation of the Help button, a dialog containing context sensitive help information will be 
displayed. 

On completion of the operation, the OpenFTA: Probabilities dialog is removed, a Probability Report is 
generated (to a file named: <fault tree name>.prp) and displayed in a dialog. The report 
consists of: 

• the directory path to the file used to store the fault tree analysed in this report  

• the date and time of the report’s creation 

• the number of unique primary events in the displayed fault tree (including those in any transfer-
in trees) 
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• the number of minimal cut sets available for the fault tree 

• the maximum order of the minimal cut sets available for use in the probability calculations for 
the displayed fault tree 

• a statement of the order of minimal cut sets utilised in the probability calculations, if less than 
the maximum order available is used 

• the unit time span used for the calculations 

• a table titled Minimal cut set probabilities. This consists of a list of all the minimal cut sets and 
the probabilities of each and every event in a minimal cut set failing in order to cause the top 
level event to occur (system failure) 

• the probability of the top level event occurring given the cut set probabilities calculated 
previously 

• a table titled Basic Event Analysis. This contains a list of all the primary events in the fault tree 
and their failure contribution towards the top-level event occurring. This contribution is also 
stated as a percentage importance value for each primary event. 

Cross References 
Analysis, Minimal Cut Sets, Print Dialog, Print (OpenFTA, Report), Report, Validate and View 
(OpenFTA, Report). 
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Open (OpenFTA) 

Control Type  
Menu Option 

Function 
Opens a previously stored fault tree for display and possible modification. 

Location 
OpenFTA menubar -> File -> Open 

Shortcuts  
Accelerator: Ctrl+O. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Used to open a fault tree that has been previously stored. On activation, a file selection dialog titled 
Open is displayed. For more details on the use of this dialog read the section titled File Selection 
Dialog. 

Note that on activation of the OK button, the currently selected file is opened and the Open dialog is 
removed. If no file, or non-existent or inaccessible files are selected then, an error dialog is displayed. 

If a fault tree has been modified without saving, then confirmation is requested before OpenFTA 
proceeds with the Open Operation.  

On successful completion of the operation, the newly chosen fault tree is displayed. 

Cross References 
File Selection Dialog. 
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Open (OpenPED) 

Control Type  
Menu Option 

Function 
Opens a previously stored primary events database for display and possible modification. 

Location 
OpenPED menubar -> File -> New 

Shortcuts  
Accelerator: Ctrl+O. 

Toolbar:  

Pre-conditions  
None. 

Operation 
Used to open a primary events database that has been previously stored. On activation, a file selection 
dialog titled Open is displayed. For more details on the use of this dialog read the section titled File 
Selection Dialog. 

Note that on activation of the OK button the currently selected file is opened and the Open dialog is 
removed. If no file, or non-existent or inaccessible files are selected then an error dialog is displayed. 

If a database has been modified without saving, then confirmation is requested before OpenFTA 
proceeds with the Open Operation.  

On successful completion of the operation the newly chosen database is displayed in the OpenPED 
window. 

Cross References 
File Selection Dialog. 
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Page Setup... 

Control Type  
Menu Option 

Function 
Invokes the page setup dialog. 

Location 
OpenFTA and OpenPED menubar -> File -> Page Setup... 

Print Preview dialog toolbar. 

Shortcuts  
Accelerator: None. 

Toolbar (Print Preview dialog only): 

Pre-conditions  
None. 

Operation 
 Invokes the page setup dialog that allows the paper size/orientation to be selected. 

Cross References 
Page Setup Dialog, Print, Print Dialog, Print Preview..., Printer Setup... 
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Page Setup Dialog 

Control Type  
Dialog 

Function 
Sets the paper size and orientation. 

Location 
Invoked from Page Setup... (OpenFTA), Page Setup... (OpenPED) and Page Setup... (Print Preview). 

Operation 
The dialog consists of: 

• a Paper panel allowing the Size and Source of the paper to be specified  

• an Orientation  panel that sets the output to be either Landscape or Portrait  

• a Margin panel where the Left, Right, Top and Bottom margin distances can be adjusted. 

 

On activation of the OK  button, the settings are confirmed and the dialog is removed from the screen. 
On activation of the Cancel button, the procedure is aborted and the dialog is removed from the screen. 

Cross References 
Page Setup..., Print, Print Dialog, Print Preview..., Printer Setup... 
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Paste (OpenFTA) 

Control Type  
Menu Option 

Function 
Places the clipboard contents as a child of the currently selected fault tree symbol. 

Location 
OpenFTA menubar -> Edit -> Paste 

Shortcuts  
Accelerator: Ctrl+V. 

Toolbar: 

Pre-conditions  
A symbol in the drawing area is selected. 

Operation 
A copy of the clipboard contents, usually a sub-tree of gates and events, is added as a child of the 
currently selected fault tree symbol. If this operation would cause the fault tree to become invalid, then 
an error dialog is displayed and the operation is aborted. The Paste operation can be repeated several 
times, since the clipboard retains its contents until they are overwritten by a Copy or Cut operation. 

Cross References 
Copy (OpenFTA), Cut (OpenFTA) and Undo. 
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Paste (OpenPED) 

Control Type  
Menu Option 

Function 
Places the clipboard contents to the place marked by the cursor into the Id, Probability or Description 
fields. 

Location 
OpenPED menubar -> Edit -> Paste 

Shortcuts  
Accelerator: Ctrl+V. 

Toolbar: 

Pre-conditions  
Text has previously been Cut or Copied onto the clipboard or, to paste into the Probability fields, data 
in a decimal or exponential format has previously been Cut or Copied  onto the clipboard. 

Operation 
A copy of the clipboard contents is added into one of the text fields where the cursor is currently 
situated. If text is currently highlighted the clipboard contents replace the highlighted text. If non 
numerical data is pasted into the Probability field, white space will be pasted instead. The Paste 
operation can be repeated several times, since the clipboard retains its contents until they are 
overwritten by a Copy or Cut operation. 

Cross References 
Copy (OpenPED), Cut (OpenPED). 
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Preferences... 

Control Type  
Menu Option 

Function 
Invokes the preferences dialog. 

Location 
OpenFTA menubar -> Edit -> Preferences... 

Shortcuts  
Accelerator: None. 

Toolbar : None. 

Pre-conditions  
None. 

Operation 
 Invokes the preferences dialog that allows the colours of the OpenFTA canvas to be changed. The 
colour of all the symbols can be specified, along with the pen, background and highlight colurs. 

Cross References 
None. 
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Print... (OpenFTA) 

Control Type  
Menu Option 

Function 
Prints the currently displayed fault tree either to a printer, or to a file. 

Location 
OpenFTA menubar -> File -> Print... 

Shortcuts  
Accelerator: Ctrl+P. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Used to print the fault tree. On activation, a dialog titled Print is displayed. For more details on the use 
of this dialog read the section entitled Print Dialog. 

Cross References 
Print Dialog. 
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Print... (OpenPED) 

Control Type  
Menu Option 

Function 
Prints the currently displayed primary events database either to a printer or to a file. 

Location 
OpenPED menubar -> File -> Print... 

Shortcuts  
Accelerator: None. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Used to print the primary events database either to a connected printer or to a file. On activation, a 
dialog titled Print is displayed. For more details read the section entitled Print Dialog. 

Cross References 
Print Dialog. 
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Print... (OpenFTA, Report) 

Control Type  
Menu Option 

Function 
Prints any of the three generated reports: Qualitative Report, Probability Report and Monte Carlo 
Report. 

Location 
OpenFTA menubar -> Report -> Print 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
On activation a slide right menu is displayed containing three options: Qualitative Report..., 
Probability Report... and Monte Carlo Report.... 

By choosing any one of the available reports, a dialog titled Print is displayed. For more details on the 
use of this dialog read the section titled Print Dialog. 

Note that if the appropriate analyses that generate the reports have not been performed, then the 
relevant options are greyed-out. For the Qualitative Report to be available for printing, the minimal cut 
sets must have been generated. For the Probability Report, the Numerical Probability analysis must 
have been carried out and for the Monte Carlo Report, the Monte Carlo Simulation must have been 
performed.  

Cross References 
Minimal Cut Sets..., Monte Carlo Simulation..., Numerical Probability... and Print Dialog. 
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Print Dialog 

Control Type  
Dialog 

Function 
Prints an image to a printer. 

Location 
Invoked from Print... (OpenFTA), Printer Setup... (OpenFTA), Print... (OpenPED), Printer Setup... 
(OpenPED) and Print... (OpenFTA, Report). 

Operation 
The dialog consists of: 

• a Printer Name list allowing the destination printer to be specified 

• a Properties button that invokes the properties dialog specific to the currently selected printer 

• a Print Range panel allowing a subset of pages to be selected for printing  

• a Copies panel where the number of required copies can be set. 

 

On activation of the OK  button, the document is sent to the selected printer and the dialog is removed 
from the screen. 

On activation of the Cancel button, the procedure is aborted and the dialog is removed from the screen. 

On activation of the Help button a dialog containing context sensitive help information is displayed. 

Cross References 
None. 
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Print Preview... 

Control Type  
Menu Option 

Function 
Invokes the Print Preview Dialog. 

Location 
OpenFTA menubar -> File -> Print Preview... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Invokes the Print Preview Dialog that controls the layout of the printed FTA canvas. 

Cross References 
Print Preview Dialog. 
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Print Preview Dialog 

Control Type  
Dialog 

Function 
Controls the layout of the printed FTA canvas. 

Location 
Invoked from Print Preview.... 

Operation 
The dialog consists of: 

• a toolbar containing 3 buttons: 

o A Printer Setup button that launches the Print Dialog allowing the selection of the 
current printer. 

o A Page Setup button that launches the Page Setup Dialog allowing the specification 
of the paper size/orientation. 

o A Print button that launches the Print Dialog allowing the FTA Canvas to be sent to 
the selected printer. 

• a window previewing what the output will look like using the current settings.  

• a Horizontal Pages spin button that adjusts the number of horizontal pages required.  

• a Vertical Pages spin button that adjusts the number of vertical pages required. 

• a Zoom spin button that adjusts the scale of the preview window. 

 

On activation of the OK  button, the current setting are confirmed  and the dialog is removed from the 
screen. 

On activation of the Cancel button, the current settings are discarded and the dialog is removed from 
the screen. 

On activation of the Help button a dialog containing context sensitive help information is displayed. 

Cross References 
Page Setup Dialog, Print Dialog and Print Preview... 
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Printer Setup... 

Control Type  
Menu Option 

Function 
Allows the selection of the target printer. 

Location 
OpenFTA and OpenPED menubar -> File -> Printer Setup... 

Print Preview dialog toolbar. 

Shortcuts  
Accelerator: None. 

Toolbar (Print Preview dialog only):  

Pre-conditions  
None. 

Operation 
 Invokes the print dialog that allows the target printer to be selected. 

Cross References 
Print, Print Dialog, , Print Preview, Page Setup... 
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Report 

Control Type  
Pulldown Menu 

Function 
Provides access to the analysis reports generated by OpenFTA. 

Location 
OpenFTA menubar -> Report. 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to access the analysis reports generated by the OpenFTA application. 

Cross References 
Minimal Cut Sets, Monte Carlo Simulation, Numerical Probability, Print (OpenFTA, Report), Validate 
and View (OpenFTA, Report). 
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Save (OpenFTA) 

Control Type  
Menu Option 

Function 
Stores the current fault tree to a file. 

Location 
OpenFTA menubar -> File -> Save 

Shortcuts  
Accelerator: Ctrl+S. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Used to store the currently displayed fault tree to a file. On activation, if the fault tree has been 
previously stored, then the tree is stored to the same file. This overwrites any previous contents held 
within the file. The file name is of the form <name of tree>.fta. 

If the tree has not been stored previously then the Save operation acts in the same way as the Save As... 
operation. 

If the output file does not have write access, then an error dialog is displayed. In order to save the fault 
tree the permissions must be changed or the Save As... operation must be used to store the fault tree to a 
file with a different name and/or directory location. 

Cross References 
Save As (OpenFTA). 
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Save (OpenPED) 

Control Type  
Menu Option 

Function 
Stores the current primary events database to a file. 

Location 
OpenPED menubar -> File -> Save 

Shortcuts  
Accelerator: Ctrl+S. 

Toolbar:  

Pre-conditions  
None. 

Operation 
Used to store the currently displayed primary events database to a file. On activation, if the database 
has been previously stored, then it is stored to the same file. This overwrites any previous contents held 
within the file. The file name is of the form <name of database>.ped. 

If the database has not been stored previously, then the Save operation acts in the same way as the Save 
As... operation. 

If the output file does not have write access, then an error dialog is displayed. In order to save the 
database the permissions must be changed or the Save As... operation must be used to store the database 
to a file with a different name and/or directory location. 

Cross References 
Save As (OpenPED). 
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Save As... (OpenFTA) 

Control Type  
Menu Option 

Function 
Stores the current fault tree to a named file.  

Location 
OpenFTA menubar -> File -> Save As... 

Shortcuts  
Accelerator: Ctrl+A. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to store the open fault tree to a named file. The file name is usually of the form <name of 
tree>.fta. 

On activation a file selection dialog titled Save, is displayed. For more details on the use of this dialog 
read the section titled File Selection Dialog. 

Note that on activation of the OK button the fault tree is stored to the currently selected file and the 
Save dialog is removed. If no file is selected then an error dialog is displayed. 

If the output file does not have write access, then an error dialog is displayed. In order to save the fault 
tree the permissions must be changed or the Save As... operation must be used to store the fault tree to a 
file with a different name and/or directory location. 

Cross References 
File Selection Dialog, Save(OpenFTA). 
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Save As... (OpenPED) 

Control Type  
Menu Option 

Function 
Stores the current primary events database to a named file. 

Location 
OpenPED menubar -> File -> Save As... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Used to store the open primary events database to a named file. The file name is of the form <name 
of database>.ped. 

On activation a selection dialog titled Save, is displayed. For more details on the use of this dialog read 
the section titled File Selection Dialog. 

Note that on activation of the OK button the database is stored to the currently selected file and the 
Save dialog is removed. If no file is selected then an error dialog is displayed. 

If the output file does not have write access, then an error dialog is displayed. In order to save the 
database the permissions must be changed or the Save As... operation must be used to store the database 
to a file with a different name and/or directory location. 

Cross References 
File Selection Dialog, Save (OpenPED). 
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Selected... 

Control Type  
Menu Option 

Function 
Displays the selected fault tree symbol’s associated information. 

Location 
OpenFTA menubar -> Edit -> Selected... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
On activation, the selected fault tree symbol’s details are displayed. For a chosen intermediate event, 
transfer symbol or logic gate, a dialog is displayed containing the pertinent information about the 
symbol. For a primary event, the relevant database entry in the OpenPED window is highlighted and 
information is displayed. 

The operation can also be activated by multi-clicking within the boundary of the required symbol in the 
fault tree. 

Cross References 
None. 
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Set Zoom... 

Control Type  
Menu Option 

Function 
Set’s the zoom value of the OpenFTA canvas. 

Location 
OpenFTA menubar -> View -> Set Zoom... 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
Invokes a dialog that allows the current zoom to be set. The zoom can be entered manually or a preset 
value selected from the drop down list. 

Cross References 
Zoom In, Zoom Out. 
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Shift Left 

Control Type  
Menu Option 

Function 
Shifts the currently selected fault tree symbol and the sub-tree below it one position to the left. 

Location 
OpenFTA menubar -> Edit -> Shift Left 

Shortcuts  
Accelerator: Ctrl+L. 

Toolbar: None. 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
On activation, the selected fault tree symbol and the sub-tree below it are shifted one place to the left. 
The layout of the fault tree is handled automatically. The operation is available for purely aesthetic 
reasons and has no effect upon the analysis of the tree.  

Note that Conditioning Events may not be shifted and if this operation is attempted an error dialog is 
displayed. 

Cross References 
Shift Right and Undo. 
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Shift Right 

Control Type  
Menu Option 

Function 
Shifts the currently selected fault tree symbol and the sub-tree below it one position to the right. 

Location 
OpenFTA menubar -> Edit -> Shift Right 

Shortcuts  
Accelerator: Ctrl+R. 

Toolbar: None. 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
On activation, the selected fault tree symbol and the sub-tree below it are shifted one place to the right. 
The layout of the fault tree is handled automatically. The operation is available for purely aesthetic 
reasons and has no effect upon the analysis of the tree.  

Note that Conditioning Events may not be shifted and if this is attempted an error dialog is displayed. 

Cross References 
Shift Left and Undo. 
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Symbol Palette 

Control Type  
Push Buttons 

Function 
The set of symbols available to draw a fault tree. 

Location 
Left hand side of the OpenFTA window 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
A symbol on the canvas is selected. 

Operation 
Selecting a symbol from the palette adds the chosen symbol as the right most child of the symbol 
selected on the canvas. 

Note that the tree layout is managed automatically and that the symbol palette is context sensitive and 
thus prevents illogical additions to the tree by greying out inappropriate symbols. 

The Symbol Palette is made up of events, gates and transfer symbols. 

 

Event Symbols: 

Intermediate Event: Used to specify a failure event that occurs due to one or more causes 
acting through logic gates below it in the fault tree. 

 

Basic Initiating Event: Used to specify a failure event that does not require any further 
development i.e. it is a “leaf” of the fault tree and has no gates or events below it in the tree. 

 

Undeveloped Event: Used to specify a failure event that is not developed as far as it could be, 
either because the event is of no importance in this fault tree, or because there is not enough 

information available. 

 

External Event: Used to specify a failure event that is expected to occur and is therefore not 
directly a failure. The event can only have a probability attached to it of 0 (Failed) or 1 

(Working). 

 

Conditioning Event: Used to specify certain conditions upon any logic gate. There are two 
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states for this type of event: Analysed - a probability is assigned to the event and it forms part of the 
analysis of the tree; Not Analysed - no probability is assigned to the event and it’s role is to add 
pertinent comments. This type of event is mainly used in conjunction with the Priority And and Inhibit 
gates and is displayed to the right of a gate. 

 

Logic Gate Symbols: 

And Gate: Used to show that the output fault will only happen if all of the inputs occur. 

 

Or Gate: Used to show that the output fault will only occur if one or more of the input faults 
take place. 

 

Priority And Gate: The output only occurs if the input faults take place in a certain order. The 
sequence of events is usually stated in a conditioning event, situated to the right of the gate. 

 

Exclusive Or Gate: The output only occurs if exactly one of the input faults happens. 

 

Inhibit Gate: The output fault only occurs if the single input happens and the attached 
Conditioning Event is satisfied. The gate is in effect a special case And gate. 

 

Transfer Symbols: 

These symbols are used to modularise a fault tree. For example, if there is  a sequence of events that 
occurs in more than one place in the fault tree, then it can be removed and placed into a separate sub-
tree and just referenced by the main fault tree. 

 

Transfer In: Used to depict a sub-tree that has been stored in a separate .fta file. The name of 
the file is used as the identifier for the transfer in symbol. Note that the .fta suffix is added 

automatically to the file name. 

 

Transfer Out: Used to depict that the tree shown below a transfer out symbol is a sub-tree of a 
fault tree that is stored in a different file. The name of the sub-tree may be used as the identifier 

for the transfer out symbol. Note that the .fta suffix is added automatically to the file name. 

Cross References 
None. 
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Tree Overview 

Control Type  
Menu Option 

Function 
Displays the entire fault tree in a resizeable window. 

Location 
OpenFTA menubar -> View -> Tree Overview 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
On activation a resizeable dialog entitled OpenFTA: Tree  is displayed. The dialog contains a scaled 
image of the fault tree currently displayed on the OpenFTA canvas area. Symbols can be selected on 
the overview causing them to become centered on OpenFTA’s canvas area. This aids navigation 
around large fault trees. 

Cross References 
None. 



Chapter 3 - OpenFTA Reference 

 
OpenFTA Version 1.0 User Manual 

 
© Copyright 2005 Formal Software Construction Ltd 

 
 

75 

Undo 

Control Type  
Menu Option 

Function 
Undoes the last edit action carried out upon the fault tree. 

Location 
OpenFTA menubar -> Edit -> Undo 

Shortcuts  
Accelerator: Ctrl+U. 

Toolbar: None. 

Pre-conditions  
One of the edit actions; Copy, Cut, Delete, Paste, Shift Left  or Shift Right has been carried out or a 
symbol has been added to the fault tree. 

Operation 
On activation, the last edit action or symbol addition to the fault tree is undone. Note that if the Undo 
option is selected twice in a row it undoes the first undo action. 

Cross References 
Copy, Cut, Delete (OpenFTA), Paste, Shift Left, Shift Right and Symbol Palette. 
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Validate 

Control Type  
Menu Option 

Function 
Verifies that the current fault tree is logically correct and ready for analysis. 

Location 
OpenFTA menubar -> Analysis -> Validate 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
The fault tree displayed on the canvas has been associated with a primary events database and been 
saved. 

Operation 
On selection of this option, a validation report is produced and displayed. The report contains any 
warnings or errors found with the fault tree and states if the tree is logically correct. 

The report is stored in the file named <fault tree name>.vrp. If the output file does not have 
write access, then an error dialog is displayed. The permissions for the file or directory must be 
changed before activating this option again. 

Cross References 
Analysis, Minimal Cut Sets, Monte Carlo Simulation and Numerical Probability. 
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View 

Control Type  
Pulldown Menu 

Function 
Provides access to facilities for displaying different views of the fault tree. 

Location 
OpenFTA menubar -> View 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Operation 
Tree Overview shows the entire tree in a window. Zoom facilities allow inspection of an area of the 
tree in greater or lesser detail. 

Pre-conditions  
None. 

Cross References 
Set Zoom..., Tree Overview..., Zoom In and Zoom Out. 
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View (OpenFTA, Report) 

Control Type  
Menu Option 

Function 
Provides a means to view any of the three generated reports: Qualitative Report, Probability Report and 
Monte Carlo Report. 

Location 
OpenFTA menubar -> Report -> View 

Shortcuts  
Accelerator: None. 

Toolbar: None. 

Pre-conditions  
None. 

Operation 
On selection of the View option a slide right menu is  displayed containing three options: Qualitative 
Report, Probability Report and Monte Carlo Report. By choosing any one of the available reports, a 
OpenFTA: View Report dialog containing the associated information is displayed. 

Note that for the Qualitative Report to be available for viewing, the minimal cut sets must have been 
generated. For the Probability Report, the Numerical Probability analysis must have been performed 
and for the Monte Carlo Report, the Monte Carlo Simulation must have been performed. If the 
appropriate analyses that generate the reports have not been done, then the relevant options are greyed-
out. 

Cross References 
Minimal Cut Sets, Monte Carlo Simulation and Numerical Probability. 
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Zoom In 

Control Type  
Menu Option 

Function 
Increases the zoom value of the OpenFTA canvas. 

Location 
OpenFTA menubar -> View -> Zoom In 

Shortcuts  
Accelerator: None. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Increases the zoom value of the OpenFTA canvas by 10%. 

Cross References 
Set Zoom..., Zoom Out. 
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Zoom Out 

Control Type  
Menu Option 

Function 
Decreases the zoom value of the OpenFTA canvas. 

Location 
OpenFTA menubar -> View -> Zoom Out 

Shortcuts  
Accelerator: None. 

Toolbar: 

Pre-conditions  
None. 

Operation 
Decreases the zoom value of the OpenFTA canvas by 10%. 

Cross References 
Set Zoom..., Zoom In. 
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Appendix A -  Analysis Methods 
 

Overview 

This appendix describes the analysis methods used to: 

• carry out the numerical probability calculations 

• carry out Monte Carlo Simulations. 

It then briefly details the P-model and ?-model used to define the probability of occurrence of a 
primary event. 

Numerical Probability Analysis 

This is calculated using a method of direct computation from the probabilities of the primary events, 
which are independent in OpenFTA. The method depends upon the logically reduced tree, but the 
precision of the result does not. This relies on the number of terms calculated in the expression for the 
top level probability (see below). Note that the same information is generated stochastically by the 
Monte Carlo method. 

The complexity of this calculation arises because the same primary event may occur in several places 
in a fault tree or, in other words, the component probabilities in the tree are not independent. 

If the minimal cut sets are M1, M2, ..., Mn, then the tree is logically equivalent to the expression: (M1 
OR M2 OR ... OR Mn). It is this expression that is evaluated. Note that the minimal cut sets are neither 
mutually exclusive nor independent. The general expression for the probability of the OR of n arbitrary 
events is: 

This is a sum of terms each of which is the probability of the AND of minimal cut sets. The probability 
of the AND of several minimal cut sets is not simply the product of their individual probabilities, as 
they may share primary events. Assuming the primary events are independent, it is the product of the 
probabilities of all the primary events that occur in any cut set, taking each one only once. 

This series however has 2N terms where N is the number of minimal cut sets. In general it would take a 
prohibitively long time to evaluate all the terms in this series, even for fairly small trees. For example, a 
tree with 20 basic events could have 100 minimal cut sets, which would imply more than 1030 terms. In 
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fact it is not necessary to evaluate all the terms. The following series gives ever-closer approximations 
to the exact result. 

 

The series has N terms, each of which has NCr sub-terms, giving 2N terms in all. The first term is 
simply the sum of probabilities of the minimal cut sets. The increments in the series alternate in sign 
and it can be shown that the terms always bracket the answer i.e. the first term is an upper bound, the 
second a lower bound, the third a better upper bound, etc. 

Thus, the result can be made arbitrarily accurate by specifying a sufficient number of terms i.e.  

 

where  

)...( 21 nMMMPP ∪∪∪=  

In practice the terms get smaller rapidly and it is rarely necessary to go past the third term for a large 
tree. For 100 minimal cut sets, the first term has 100 sub-terms, the second 4950, the third 161,700 and 
the fourth 3,921,225. It is safest to calculate the default two terms first, progressing to higher terms one 
at a time, if necessary. 

Monte Carlo Simulation 

The principle behind the Monte Carlo methodology is to simulate occurrences of the primary events 
(component failures), using a random number generator.  

For each trial, each primary event is simulated by generating a (pseudo-)random real number in the 
range 0 to 1 inclusive. If this number is less than or equal to the probability of the primary event, the 
event is deemed to have occurred and its value is set to TRUE. Otherwise it is deemed not to have 
occurred and its value is set to FALSE.  

The fault tree is then evaluated with these values for the primary events to see if the top event occurs 
(system failure). The number of top event occurrences is stored, together with the corresponding failure 
mode (the list of primary events which occurred to cause the top event).  
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The data is then used to obtain both the top-level probability and the probabilities of individual cut sets. 
For example, for N trials resulting in F failures the probability would be estimated as (F±vF)/N. 

One refinement of this scheme is made. Consider a tree with 30 primary events, with probabilities of 
the order of 10-3. In this case in approximately 97% of trials, no primary event would occur and the 
fault tree would be evaluated with no faults. All these runs would be effectively useless and therefore a 
waste of computational time.  

To avoid this, only trials in which at least one primary event occurs are simulated. The probability, P, 
of at least one primary event occurring is evaluated exactly. Thus, the probability of the top event 
occurring is estimated as P·(F±�F)/N. 

It should be noted that the failure modes generated by this method are not minimal. For example, if 
{A} and {BC} are minimal cut sets, the Monte Carlo method will report {A}, {AB},{AC},{BC} and 
{ABC} separately. To deal with this, the Monte Carlo Report generated by OpenFTA provides a 
Compressed list of cut sets, in which supersets of other cut sets are removed. 

These compressed cut sets are likely to be, but are not guaranteed to be, minimal. When a set is 
removed, its failure count is added to each of its subsets. Consider the previous example, a failure 
{ABC} would count as both {A} and {BC}.  

Note that the sum of failures for all the compressed cut sets will therefore be greater than the total 
number of failures. This is consistent with the probabilities generated in the numerical probability 
analysis. 

The P-model and the ?-model 

OpenFTA supports the P-model or ?-model definition of the probability of a primary event occurring. 

A P-model definition is used to state the probability of an event occurring when the time to failure 
(event occurring) is unknown or unpredictable. 

A ?-model definition is used to state the probability that a primary event will occur within a given 
period of time. A ?-model definition is appropriate for events within systems that are continuously 
operating and have a known probability of failure during a unit time period. 

Each event defined in terms of the ? -model has a probability of failure given by:  

1 - e- ?  r, where t = unit time to event occurring and l = constant.1 

Events defined in terms of the P-model do not have to be modified for time. The probability of a cut set 
is the multiplication of the probabilities of the events within it, as determined by the P or ? models. 

                                                 
1.  For more details see the Fault Tree Handbook, U.S. Nuclear Regulatory Commission, NUREG-0492 
and Introduction to Reliability Engineering, E. E. Lewis. 
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Appendix B - The Three Motor Example 
 

Overview 

This appendix briefly describes an example 2 of a system suitable for analysis by OpenFTA and presents 
the results of such an analysis. The data files generated are included in the OpenFTA delivery package. 

Three Motor Example 

 

Figure 14: Power Distribution Box. 

The above figure displays a power distribution box. With contacts KT1, KT2 and KT3 normally closed, 
a momentary depression of button S1 applies power from Battery 1 to the coils of relays K1 and K2. 
K1 and K2 close and remain electrically latched. 

Next, a 60 second signal is passed through K3, in order to test the operation of Motors 1, 2 and 3. Once 
K3 has closed, power from Battery 1 is applied to the coils of relays K4 and K5. The closure of K4 
starts Motor 1. The closure of K5 applies power from Battery 2 to the coil of K6 and also starts Motor 
2. Finally, the closure of K6 applies power from Battery 1 to the coil of K7. Closure of K7 starts Motor 
3. 

                                                 
2.  This example is based on one presented in the Fault Tree Handbook, U.S. Nuclear Regulatory 
Commission, NUREG-0492. 
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After 60 seconds, K3 is supposed to open, shutting down all three motors. Should K3 fail closed after 
this time, all three timers (KT1, KT2, KT3) open, de-energizing the coil of K1, thus shutting down the 
system.  

Suppose K3 opens properly after the 60 seconds, but K4 fails closed. In that case KT1 opens to 
denergize K1 and Motor 1 stops. KT2 and KT3 act similarly to stop Motor 2 or Motor 3 should either 
K5 or K7 fail closed. 

Now it can be seen that the main concern is the application of ElectroMotive Force (EMF) to the 
motors overrunning the 60 seconds.  

For this problem we will concentrate on the failures of relays and switches pertaining to Motor 2. Thus 
the top level event for the fault tree will be: EMF applied to Motor 2 for t > 60 seconds. 
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The Top Level Fault Tree 
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The Transferred Fault Tree 
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The Qualitative Analysis Report 

This report shows an example of the results obtained by generating minimal cut sets for a fault tree. 
The minimal cut sets for each order and the distribution of minimal cut sets to orders is displayed. 

 

Minimal Cut Sets 

================ 

 

Tree   : Three Motor Example (Motor 2 Only).fta 

Time   : Thu Feb 28 13:19:13 2002 

 

Method : Algebraic 

 

No. of primary events = 18 

Minimal cut set order = 1 to 18 

 

Order 1: 

 

Order 2: 

    1)  K1 K5                                             

    2)  K1 T2                                             

    3)  K2 K5                                             

    4)  K5 S1                                             

    5)  K5 T1                                             

    6)  K5 T3                                             

    7)  S1 T2                                             

 

Order 3: 

    1)  K2 T1inc T2                                       

    2)  T1 T1inc T2                                       

    3)  T1inc T2 T3                                       

 

Order 4: 

    1)  K5 KT1 KT2 KT3                                    

    2)  K5 KT1 KT3 T4                                     

 

Order 5: 
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    1)  K2 KT1inc KT2inc KT3inc T2                        

    2)  K2 KT1inc KT2inc T2 T4inc                         

    3)  K2 KT1inc KT3inc T2 T3inc                         

    4)  K2 KT1inc T2 T3inc T4inc                          

    5)  K2 KT2inc KT3inc T2 T2inc                         

    6)  K2 KT2inc T2 T2inc T4inc                          

    7)  K2 KT3inc T2 T2inc T3inc                          

    8)  K2 T2 T2inc T3inc T4inc                           

    9)  KT1 KT2 KT3 T1inc T2                              

   10)  KT1 KT3 T1inc T2 T4                               

   11)  KT1inc KT2inc KT3inc T1 T2                        

   12)  KT1inc KT2inc KT3inc T2 T3                        

   13)  KT1inc KT2inc T1 T2 T4inc                         

   14)  KT1inc KT2inc T2 T3 T4inc                         

   15)  KT1inc KT3inc T1 T2 T3inc                         

   16)  KT1inc KT3inc T2 T3 T3inc                         

   17)  KT1inc T1 T2 T3inc T4inc                          

   18)  KT1inc T2 T3 T3inc T4inc                          

   19)  KT2inc KT3inc T1 T2 T2inc                         

   20)  KT2inc KT3inc T2 T2inc T3                         

   21)  KT2inc T1 T2 T2inc T4inc                          

   22)  KT2inc T2 T2inc T3 T4inc                          

   23)  KT3inc T1 T2 T2inc T3inc                          

   24)  KT3inc T2 T2inc T3 T3inc                          

   25)  T1 T2 T2inc T3inc T4inc                           

   26)  T2 T2inc T3 T3inc T4inc                           

 

Order 6: 

 

Order 7: 

    1)  KT1 KT1inc KT2 KT2inc KT3 KT3inc T2               

    2)  KT1 KT1inc KT2 KT2inc KT3 T2 T4inc                

    3)  KT1 KT1inc KT2 KT3 KT3inc T2 T3inc                

    4)  KT1 KT1inc KT2 KT3 T2 T3inc T4inc                 

    5)  KT1 KT1inc KT2inc KT3 KT3inc T2 T4                

    6)  KT1 KT1inc KT2inc KT3 T2 T4 T4inc                 

    7)  KT1 KT1inc KT3 KT3inc T2 T3inc T4                 

    8)  KT1 KT1inc KT3 T2 T3inc T4 T4inc                  

    9)  KT1 KT2 KT2inc KT3 KT3inc T2 T2inc                
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   10)  KT1 KT2 KT2inc KT3 T2 T2inc T4inc                 

   11)  KT1 KT2 KT3 KT3inc T2 T2inc T3inc                 

   12)  KT1 KT2 KT3 T2 T2inc T3inc T4inc                  

   13)  KT1 KT2inc KT3 KT3inc T2 T2inc T4                 

   14)  KT1 KT2inc KT3 T2 T2inc T4 T4inc                  

   15)  KT1 KT3 KT3inc T2 T2inc T3inc T4                  

   16)  KT1 KT3 T2 T2inc T3inc T4 T4inc                   

 

Order 8: 

 

Order 9: 

 

Order 10: 

 

Order 11: 

 

Order 12: 

 

Order 13: 

 

Order 14: 

 

Order 15: 

 

Order 16: 

 

Order 17: 

 

Order 18: 

 

 

Qualitative Importance Analysis: 

 

Order        Number 

-----        ------ 

   1           0 

   2           7 

   3           3 

   4           2 
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   5           26 

   6           0 

   7           16 

   8           0 

   9           0 

  10           0 

  11           0 

  12           0 

  13           0 

  14           0 

  15           0 

  16           0 

  17           0 

  18           0 

  ALL          54 
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The Probability Analysis Report 

This report shows an example of the results obtained when a quantitative evaluation is performed upon 
the minimal cut sets of a fault tree. The evaluation produces the minimal cut set probabilities according 
to the defined primary event probabilities. A series expansion is then performed to calculate the 
probability of occurrence of the top level event of the fault tree for the given minimal cut sets. This 
series expansion is detailed in Appendix A. The number of terms is user definable, but the calculation 
time of the series will increase quickly as the number of terms is increased, with only a relatively small 
gain in precision. 

A primary event analysis is carried out and the failure contribution and importance of each primary 
event is  displayed. 

 

Probabilities Analysis 

====================== 

 

Tree   : Three Motor Example (Motor 2 Only).fta 

Time   : Thu Feb 28 13:19:37 2002 

 

Number of primary events   = 18 

Number of minimal cut sets = 54 

Order of minimal cut sets  = 18 

 

Unit time span         = 1.000000 

 

Minimal cut set probabilities : 

 

  1    K1 K5                           4.000000E-004 

  2    K1 T2                           4.000000E-004 

  3    K2 K5                           4.000000E-004 

  4    K5 S1                           4.000000E-004 

  5    K5 T1                           4.000000E-004 

  6    K5 T3                           4.000000E-004 

  7    S1 T2                           4.000000E-004 

  8    K2 T1inc T2                     8.000000E-006 

  9    T1 T1inc T2                     8.000000E-006 

 10    T1inc T2 T3                     8.000000E-006 

 11    K5 KT1 KT2 KT3                  1.600000E-007 

 12    K5 KT1 KT3 T4                   1.600000E-007 

 13    K2 KT1inc KT2inc KT3inc T2      3.200000E-009 
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 14    K2 KT1inc KT2inc T2 T4inc       3.200000E-009 

 15    K2 KT1inc KT3inc T2 T3inc       3.200000E-009 

 16    K2 KT1inc T2 T3inc T4inc        3.200000E-009 

 17    K2 KT2inc KT3inc T2 T2inc       3.200000E-009 

 18    K2 KT2inc T2 T2inc T4inc        3.200000E-009 

 19    K2 KT3inc T2 T2inc T3inc        3.200000E-009 

 20    K2 T2 T2inc T3inc T4inc         3.200000E-009 

 21    KT1 KT2 KT3 T1inc T2            3.200000E-009 

 22    KT1 KT3 T1inc T2 T4             3.200000E-009 

 23    KT1inc KT2inc KT3inc T1 T2      3.200000E-009 

 24    KT1inc KT2inc KT3inc T2 T3      3.200000E-009 

 25    KT1inc KT2inc T1 T2 T4inc       3.200000E-009 

 26    KT1inc KT2inc T2 T3 T4inc       3.200000E-009 

 27    KT1inc KT3inc T1 T2 T3inc       3.200000E-009 

 28    KT1inc KT3inc T2 T3 T3inc       3.200000E-009 

 29    KT1inc T1 T2 T3inc T4inc        3.200000E-009 

 30    KT1inc T2 T3 T3inc T4inc        3.200000E-009 

 31    KT2inc KT3inc T1 T2 T2inc       3.200000E-009 

 32    KT2inc KT3inc T2 T2inc T3       3.200000E-009 

 33    KT2inc T1 T2 T2inc T4inc        3.200000E-009 

 34    KT2inc T2 T2inc T3 T4inc        3.200000E-009 

 35    KT3inc T1 T2 T2inc T3inc        3.200000E-009 

 36    KT3inc T2 T2inc T3 T3inc        3.200000E-009 

 37    T1 T2 T2inc T3inc T4inc         3.200000E-009 

 38    T2 T2inc T3 T3inc T4inc         3.200000E-009 

 39    KT1 KT1inc KT2 KT2inc KT3       1.280000E-012 

       KT3inc T2           

 40    KT1 KT1inc KT2 KT2inc KT3 T2    1.280000E-012 

       T4inc               

 41    KT1 KT1inc KT2 KT3 KT3inc T2    1.280000E-012 

       T3inc               

 42    KT1 KT1inc KT2 KT3 T2 T3inc     1.280000E-012 

       T4inc               

 43    KT1 KT1inc KT2inc KT3 KT3inc    1.280000E-012 

       T2 T4               

 44    KT1 KT1inc KT2inc KT3 T2 T4     1.280000E-012 

       T4inc               

 45    KT1 KT1inc KT3 KT3inc T2        1.280000E-012 

       T3inc T4            
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 46    KT1 KT1inc KT3 T2 T3inc T4      1.280000E-012 

       T4inc               

 47    KT1 KT2 KT2inc KT3 KT3inc T2    1.280000E-012 

       T2inc               

 48    KT1 KT2 KT2inc KT3 T2 T2inc     1.280000E-012 

       T4inc               

 49    KT1 KT2 KT3 KT3inc T2 T2inc     1.280000E-012 

       T3inc               

 50    KT1 KT2 KT3 T2 T2inc T3inc      1.280000E-012 

       T4inc               

 51    KT1 KT2inc KT3 KT3inc T2        1.280000E-012 

       T2inc T4            

 52    KT1 KT2inc KT3 T2 T2inc T4      1.280000E-012 

       T4inc               

 53    KT1 KT3 KT3inc T2 T2inc T3inc   1.280000E-012 

       T4                  

 54    KT1 KT3 T2 T2inc T3inc T4       1.280000E-012 

       T4inc               

 

 

Probability of top level event (minimal cut sets up to order 18 used): 

 

 1 term    +2.824405E-003   = 2.824405E-003 (upper bound) 

 2 terms   -1.072849E-004   = 2.717120E-003 (lower bound) 

 3 terms   +3.382002E-006   = 2.720502E-003 (upper bound) 

 

 

Primary Event Analysis: 

 

 Event          Failure contrib.    Importance 

 

 K1             8.000000E-004            29.41% 

 K2             4.080256E-004            15.00% 

 K5             2.000320E-003            73.53% 

 KT1            3.264205E-007             0.01% 

 KT1inc         3.841023E-008             0.00% 

 KT2            1.632102E-007             0.01% 

 KT2inc         3.841023E-008             0.00% 

 KT3            3.264205E-007             0.01% 
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 KT3inc         3.841023E-008             0.00% 

 S1             8.000000E-004            29.41% 

 T1             4.080256E-004            15.00% 

 T1inc          2.400640E-005             0.88% 

 T2             8.240832E-004            30.29% 

 T2inc          3.841023E-008             0.00% 

 T3             4.080256E-004            15.00% 

 T3inc          3.841023E-008             0.00% 

 T4             1.632102E-007             0.01% 

 T4inc          3.841023E-008             0.00%  



Chapter 3 - OpenFTA Reference 

 
OpenFTA Version 1.0 User Manual 

 
© Copyright 2005 Formal Software Construction Ltd 

 
 

97 

The Monte Carlo Report 

This report shows an example of the results obtained when a Monte Carlo Simulation is performed 
upon a fault tree. The simulation produces the probability of at least one component failing, the 
probability of the top-level event occurring and the cut sets of the fault tree. It does this using the 
method detailed in Appendix A. The number of tests (simulations) is user definable, but the calculation 
time of the probabilities will increase as the number of tests is increased. 

A primary event analysis is carried out and the failure contribution and importance of each primary 
event is displayed.  

 

Monte Carlo Simulation 

====================== 

 

Tree   : Three Motor Example (Motor 2 Only).fta 

Time   : Thu Feb 28 13:22:20 2002 

 

Note: Only runs with at least one component failure are simulated 

 

Number of primary events  = 18 

Number of tests           = 250000 

Unit Time span used       = 1.000000 

 

Number of system failures = 2288 

 

Probability of at least   = 3.048647E-001  ( exact ) 

one component failure 

 

Probability of top event  = 2.790121E-003  ( +/- 5.833042E-005 ) 

 

Rank   Failure mode         Failures  Estimated Probability               Importance 

 

  1    K5 T3                267       3.255955E-004 ( +/- 1.992612E-005 )  11.67% 

  2    K5 S1                261       3.182787E-004 ( +/- 1.970096E-005 )  11.41% 

  3    K2 K5                257       3.134009E-004 ( +/- 1.954941E-005 )  11.23% 

  4    S1 T2                252       3.073036E-004 ( +/- 1.935831E-005 )  11.01% 

  5    K5 T1                235       2.865728E-004 ( +/- 1.869395E-005 )  10.27% 

  6    K1 K5                231       2.816949E-004 ( +/- 1.853417E-005 )  10.10% 

  7    K1 T2                217       2.646225E-004 ( +/- 1.796375E-005 )   9.48% 

  8    K1 T2 T2inc          11        1.341405E-005 ( +/- 4.044487E-006 )   0.48% 

  9    K1 KT1inc T2         9         1.097513E-005 ( +/- 3.658376E-006 )   0.39% 
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 10    K1 K5 T4             9         1.097513E-005 ( +/- 3.658376E-006 )   0.39% 

 11    K5 KT1inc T1         8         9.755669E-006 ( +/- 3.449150E-006 )   0.35% 

 12    KT3 S1 T2            8         9.755669E-006 ( +/- 3.449150E-006 )   0.35% 

 13    K2 K5 T4inc          8         9.755669E-006 ( +/- 3.449150E-006 )   0.35% 

 14    K2 T1inc T2          7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 15    K1 K5 T3             7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 16    K1 K5 KT2            7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 17    K5 KT1inc S1         7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 18    K1 KT3 T2            7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 19    K5 KT1 S1            7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 20    K5 KT3 T3            7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 21    S1 T2 T3inc          7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 22    K5 S1 T2             7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 23    K5 T1 T2inc          7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 24    S1 T2 T2inc          7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 25    K2 K5 T2inc          7         8.536211E-006 ( +/- 3.226384E-006 )   0.31% 

 26    K5 T2inc T3          6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 27    K1 S1 T2             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 28    S1 T2 T3             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 29    S1 T2 T4             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 30    K2 K5 T3inc          6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 31    K1 T2 T4             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 32    KT2inc S1 T2         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 33    K2 K5 T1             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 34    K1 KT3inc T2         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 35    K5 T3 T4inc          6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 36    K5 KT1inc T3         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 37    K5 S1 T3inc          6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 38    S1 T1 T2             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 39    K5 KT3inc T1         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 40    K5 KT2 S1            6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 41    K5 KT3inc T3         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 42    K1 K5 KT2inc         6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 43    K5 S1 T4             6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 44    K5 KT3 S1            6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 45    K5 KT2inc S1         5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 46    K2 K5 T4             5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 47    T1inc T2 T3          5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 48    K5 T1 T4inc          5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 
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 49    K2 K5 T3             5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 50    K1 T1 T2             5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 51    K1 T1inc T2          5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 52    K5 KT2 T3            5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 53    K5 KT2inc T1         5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 54    K2 K5 KT1            5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 55    K1 K5 T1             5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 56    K5 S1 T1inc          5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 57    K5 T3 T4             5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 58    S1 T1inc T2          5         6.097293E-006 ( +/- 2.726792E-006 )   0.22% 

 59    K1 T2 T3inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 60    K5 KT2inc T3         4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 61    K5 S1 T1             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 62    K1 KT1 T2            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 63    K1 K2 T2             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 64    K5 T1 T1inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 65    K1 K5 T2inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 66    K5 S1 T4inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 67    K1 K5 S1             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 68    K2 K5 S1             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 69    K5 T1inc T3          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 70    K5 KT3inc S1         4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 71    KT2 S1 T2            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 72    K1 KT2 T2            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 73    K1 K2 K5             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 74    K5 T1 T3             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 75    KT1inc S1 T2         4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 76    K1 K5 KT3            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 77    K1 K5 KT1            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 78    K2 K5 KT1inc         4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 79    K5 S1 T2inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 80    K1 T2 T4inc          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 81    K5 T2 T3             4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 82    K2 K5 KT2            4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 83    K2 K5 T2             3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 84    K1 T2 T3             3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 85    KT1 S1 T2            3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 86    K1 K5 KT3inc         3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 87    K2 S1 T2             3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 
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 88    K2 K5 T1inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 89    KT3inc S1 T2         3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 90    K1 K5 T4inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 91    S1 T2 T4inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 92    T1 T1inc T2          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 93    K5 T1 T2             3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 94    K1 K5 T1inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 95    K5 KT3 T1            3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 96    K5 T1 T3inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 97    K1 K5 KT1inc         3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 98    K5 KT1 T3            3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

 99    K5 S1 T3             3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

100    K5 T3 T3inc          3         3.658376E-006 ( +/- 2.112164E-006 )   0.13% 

101    K1 KT3 T2 T4         2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

102    K1 KT2inc T2         2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

103    K1 K5 T3inc          2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

104    K2 K5 KT2inc         2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

105    K2 K5 KT3            2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

106    K5 KT2 S1 T4         2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

107    K5 KT1inc KT2inc T1  2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

108    K5 KT1 T1            2         2.438917E-006 ( +/- 1.724575E-006 )   0.09% 

109    K5 KT2inc T1 T4inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

110    K5 KT1 KT3inc S1     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

111    K5 T1inc T3 T4inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

112    KT2inc KT3 S1 T2     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

113    K2 S1 T2 T4inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

114    K1 KT2inc KT3inc T2  1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

115    K1 KT1 KT3inc T1inc  1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

       T2                  

116    K1 K2 T2 T3          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

117    S1 T2 T2inc T4       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

118    K1 K5 KT1inc KT2     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

119    K2 K5 KT3inc T2inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

120    K1 K5 KT2inc T4      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

121    K5 KT2inc T1inc T3   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

122    S1 T1inc T2 T4inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

123    K5 T1 T3 T3inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

124    K2 K5 KT1inc KT3     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

125    K1 K2 K5 T2          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 
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126    KT3 KT3inc S1 T2     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

127    K1 K5 KT2 T1         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

128    K1 KT2inc T2 T3      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

129    S1 T1inc T2 T3inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

130    K5 KT2 KT3 S1        1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

131    K1 K5 S1 T1inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

132    K1 K5 KT1inc KT2inc  1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

133    K2 K5 KT3 S1         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

134    K5 KT3inc T1 T2      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

135    K5 T2 T2inc T3       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

136    K5 T1 T4             1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

137    K1 K5 T2inc T3inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

138    K5 KT2inc T3 T4inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

139    K2 T1inc T2 T3       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

140    K5 KT2inc KT3 T1     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

141    K5 KT2 T1            1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

142    K2 K5 T4 T4inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

143    K1 K5 T2             1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

144    K5 KT3inc T3 T4inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

145    K5 KT1 KT3 T4        1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

146    K5 T1 T3 T4inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

147    K2 K5 T3 T4inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

148    K1 KT1inc KT2 T2     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

149    K5 KT3 KT3inc S1 T2  1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

150    K2 KT3 T1inc T2      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

151    KT1inc KT2 S1 T2     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

152    K5 KT3 T1 T2         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

153    K5 KT1 S1 T3 T4inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

154    K1 K5 T2 T2inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

155    K2 K5 T2 T4inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

156    K1 K5 KT2 T3 T3inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

157    K5 S1 T1inc T2inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

158    K2 K5 KT1 T1         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

159    K1 K5 T1inc T2inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

160    K1 K2 K5 KT1inc      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

161    K2 K5 KT3 T1 T4inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

162    K2 K5 KT2 T4         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

163    K5 KT2 KT2inc T1     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

164    K2 K5 KT1 T2         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 
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165    K5 KT1inc S1 T1inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

166    KT1inc S1 T2 T2inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

167    K2 K5 KT1 T3         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

168    K1 K5 S1 T4          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

169    K2 K5 KT2 KT3 T4     1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

170    K1 KT3 T1 T2         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

171    K1 S1 T2 T2inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

172    KT3inc T1 T1inc T2   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

173    K2 T1inc T2 T4       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

174    K5 KT3inc S1 T3      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

175    K2 S1 T2 T4          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

176    K5 T1 T2inc T4       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

177    K1 KT3inc T1inc T2   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

178    K2 K5 KT3inc         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

179    K1 K5 KT3 T3inc      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

180    K1 K2 K5 T1          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

181    K5 KT3 T1 T4         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

182    K2 KT2 S1 T2         1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

183    K1 KT2inc T1 T2      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

184    K1 K5 T1inc T3inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

185    K2 K5 T1inc T2inc    1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

186    K5 S1 T1 T3          1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

187    K2 KT2 T1inc T2      1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

188    K1 K5 KT1inc T2inc   1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

189    K1 K2 K5 T1inc       1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

 

 

Compressed: 

 

Rank   Failure mode         Failures  Estimated Probability    Importance 

 

  1    K5 T3                358       4.365662E-004 ( +/- 2.307324E-005 )  15.65% 

  2    K5 S1                356       4.341273E-004 ( +/- 2.300870E-005 )  15.56% 

  3    K2 K5                343       4.182743E-004 ( +/- 2.258469E-005 )  14.99% 

  4    S1 T2                348       4.243716E-004 ( +/- 2.274871E-005 )  15.21% 

  5    K5 T1                318       3.877879E-004 ( +/- 2.174606E-005 )  13.90% 

  6    K1 K5                317       3.865684E-004 ( +/- 2.171184E-005 )  13.85% 

  7    K1 T2                311       3.792516E-004 ( +/- 2.150539E-005 )  13.59% 

  8    K2 T1inc T2          11        1.341405E-005 ( +/- 4.044487E-006 )   0.48% 
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  9    T1inc T2 T3          6         7.316752E-006 ( +/- 2.987051E-006 )   0.26% 

 10    T1 T1inc T2          4         4.877835E-006 ( +/- 2.438917E-006 )   0.17% 

 11    K5 KT1 KT3 T4        1         1.219459E-006 ( +/- 1.219459E-006 )   0.04% 

 

 

Primary Event Analysis: 

 

 Event          Failure contrib.    Importance 

 

 K1             7.658200E-004            27.45% 

 K2             4.316884E-004            15.47% 

 K5             2.064544E-003            73.99% 

 KT1            1.219459E-006             0.04% 

 KT1inc         0.000000E+000             0.00% 

 KT2            0.000000E+000             0.00% 

 KT2inc         0.000000E+000             0.00% 

 KT3            1.219459E-006             0.04% 

 KT3inc         0.000000E+000             0.00% 

 S1             8.584989E-004            30.77% 

 T1             3.926657E-004            14.07% 

 T1inc          2.560863E-005             0.92% 

 T2             8.292320E-004            29.72% 

 T2inc          0.000000E+000             0.00% 

 T3             4.438829E-004            15.91% 

 T3inc          0.000000E+000             0.00% 

 T4             1.219459E-006             0.04% 

 T4inc          0.000000E+000             0.00% 
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The Primary Event Database Report 

This report shows an example of the primary events in a primary events database. It details the Id, 
Type, Description, Probability of each and every event in the database. 

 

Primary Events Database 

======================= 

 

Database Filename: Three Motor Example (Motor 2 Only).ped 

 

ID: T3 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: Reset signal inadvertently applied or not removed from switch S1 

 

ID: S1 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: S1 switch inadvertently closes or fails to open 

 

ID: T4 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: KT2 timer does not time "time out" due to improper installation or 
setting 

 

ID: KT2 

Probability: 0.02 

Type: External 

Dormant: No 

Description: KT2 timer reset 

 

ID: KT3 

Probability: 0.02 

Type: External 

Dormant: No 
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Description: KT3 timer reset 

 

ID: KT1 

Probability: 0.02 

Type: External 

Dormant: No 

Description: KT1 timer reset 

 

ID: T1 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: EMF to K2 coil through S1, KT1, KT2 & KT3 circuits 

 

ID: K2 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: K2 relay contacts fail to open 

 

ID: T2 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: Test signal remains on K3 coil for t>60 sec 

 

ID: K5 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: K5 relay contacts fail to open 

 

ID: K1 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: K1 relay contacts fail to open 

 

ID: KT1inc 
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Probability: 0.02 

Type: Basic 

Dormant: No 

Description: KT1 timer contacts fail to open 

 

ID: KT2inc 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: KT2 timer contacts fail to open 

 

ID: KT3inc 

Probability: 0.02 

Type: Basic 

Dormant: No 

Description: KT3 timer contacts fail to open 

 

ID: T1inc 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: Reset signal inadvertently applied or not removed from switch S1 

 

ID: T2inc 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: KT1 timer does not "time out" due to improper installation or setting 

 

ID: T3inc 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 

Description: KT2 timer does not "time out" due to improper installation or setting 

 

ID: T4inc 

Probability: 0.02 

Type: Undeveloped 

Dormant: No 
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Description: KT3 timer does not "time out" due to improper installation or setting 


