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When generating Gerber File output, configuration of output 
options prior to generation is performed using the Gerber 
Setup dialog. 

 

The Gerber Setup dialog is divided into the following tabs: 

General tab 

 
Figure 1. The Gerber Setup General tab as accessed from File » Fabrication Outputs » Gerber Files. 

Use this tab to specify the units and format to be used in the Gerber output files. The units can be 
either inches or millimeters. 
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The format specifies the precision of the coordinate data, which must be selected to suit the placement 
precision of the objects in the PCB workspace. For example, the 2:3 format has a resolution of 1 mil (1 
thousandth of an inch). If your design has objects placed on a sub 1 mil grid then this format will not be 
adequate. Conversely, the higher precision formats may be more difficult and expensive to photoplot 
and manufacture. 

Layers tab 

 
Figure 2.The new Gerber Setup Layers tab displays layer stackups for embedded board arrays. Notice here that 
any compatibility violations display in red. 

Use this tab to enable each layer that you want to generate a Gerber file for. You can also specify, for 
each layer, whether a mirrored Gerber file is to be created. 

You can also nominate which mechanical layer(s) are to be added to all Gerber plots. 

When generating Gerber output from a PCB design that contains embedded board arrays (shown in 
Error! Reference source not found.), the design is analyzed automatically for layer stackup violations.  

• Embedded boards that are flipped will display their layer stacks as flipped.  

• Mid signal layers and internal planes that are different can still appear on the same mid layer panel.  

• Mid signal layers and internal planes can be flipped against each other. 
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Drill Drawing tab 

 
Use this tab to specify which layer-pairs a drill drawing is required for (mirrored output files can also be 
generated). You can also specify the type and size of drawing symbol to be used to represent the 
various drill sizes. 

Use this tab also, to specify which layer-pairs a drill guide file is required for (mirrored output files can 
also be generated). The drill guide is a plot of the location of each drill site on the PCB, with each site 
marked with a small cross. 
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Apertures tab 

 
Use this tab to enable/setup the required aperture information for the design. 
When you enable the Embedded apertures (RS274X) option, the aperture list is created automatically, 
each time you generate the Gerber files. The apertures are then embedded in the Gerber files, 
according to the RS274X standard. This feature means that you do not need to worry about whether 
the current aperture list includes all the required apertures. 

If you do not enable this option, the main apertures region of the tab becomes enabled, from where you 
can load, create, edit and save an aperture table exactly as you require. 

4 OG0101 (v1.1) April 12, 2007 



 Gerber Output Options 

 
When creating new apertures, the DCode dialog appears. You can define up to a maximum of 1000 
different draft codes, in the range D00-D9999, although some of these codes (usually D00-D09) may 
be "reserved" when targeting some plotters, so use of these codes is not generally recommended. Do 
not include the "D" in any new draft code you enter. 

 
After entering a new code, you will be transferred to edit mode and the Aperture dialog will appear, 
from where you can edit the properties of the aperture as required. 
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Any changes made are applied to the aperture file currently loaded into memory. These changes do 
not become permanent until you use the Save button (on the Apertures tab of the Gerber Setup 
dialog). 

Advanced tab 

 
Use this tab to specify options such as the virtual film size to be used during Gerber generation, 
aperture matching tolerances and the use of zero suppression. 
The Gerber data can be automatically centered on the specified film by enabling the Center on film 
option. 

Use this tab to also specify the type of output plotter to be used - either vector or raster. 
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Generated Gerber Files 
The following table lists each of the Gerber files that can possibly be generated as output from a PCB 
document. In each case, the Gerber file is generated with the same name as the PCB document (i.e. 
PCBDesignName.GerberExtension). 

Gerber Extension Description 

G1, G2, etc Mid-layer 1, 2, etc 

GBL Bottom Layer 

GBO Bottom Overlay 

GBP Bottom Paste Mask 

GBS Bottom Solder Mask 

GD1, GD2, etc Drill Drawing (assignment based on order of drill 
pairs appearing in the Drill-Pair Manager dialog) 

GG1, GG2, etc Drill Guide (assignment based on order of drill pairs 
appearing in the Drill-Pair Manager dialog) 

GKO Keep Out Layer 

GM1, GM2, etc Mechanical Layer 1, 2, etc 

GP1, GP2, etc Internal Plane Layer 1, 2, etc 

GPB Pad Master Bottom 

GPT Pad Master Top 

GTL Top Layer 

GTO Top Overlay 

GTP Top Paste Mask 

GTS Top Solder Mask 

P01, P02, etc Gerber Panels 

APR Aperture File (generated when embedded apertures 
(RS274X) are used) 

APT Aperture File (generated when embedded apertures 
(RS274X) are not used) 

In addition, the following files are also generated: 
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• PCBDesignName.rul – this file contains all design rules defined for the source PCB document 
from which the Gerber data is being generated. This file is generated provided that the Generate DRC 
Rules export file (.RUL) option is enabled on the Advanced tab of the Gerber Setup dialog. 
• PCBDesignName.rep – this file provides a generation report, showing which Gerber files have 
been generated. 

When embedded apertures (RS274X) are not used, a separate text-based aperture file will be 
generated for each generated Gerber layer - for example, GBL will have an associated aperture file 
with extension ABL. Each of these files is identical in its content. The true Gerber aperture file is 
distinguished by its .apt extension in this case. 

Notes 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options 
available. Simply click on the question mark button at the top right of the dialog and then click over a 
field or option to pop-up information specific to that field or option. 

 

Gerber output can be generated in one of two ways: 

• Using an appropriately configured output generator defined in an Output Job Configuration file 
(*.OutJob). Output will be generated upon running the configured output generator 

• Directly from within the active PCB document using the File » Fabrication Outputs » Gerber 
Files menu command. Output will be generated immediately upon clicking OK in the Gerber Setup 
dialog. 
Note: The settings defined in the Gerber Setup dialog when generating output directly from the PCB 
are distinct and separate to those defined for the same output type in an Output Job Configuration file. 
In the case of the former, the settings are stored in the project file, whereas for the latter they are 
stored in the Output Job Configuration file. 

 

When generating Gerber output, you can specify that the output be opened automatically in a new 
CAMtastic document. The way in which this is accomplished depends on how you are generating the 
output: 
• From an Output Job Configuration file - enable the Gerber Output auto-load option in the Output 
Job Options dialog (Tools » Output Job Options from the OutputJob Editor) 

• Directly from the PCB - ensure that the Open outputs after compile option is enabled on the 
Options tab of the Options For Project dialog (Project » Project Options). 

 

Unless your PCB manufacturer does not support embedded apertures it is highly recommended that 
you use the Embedded apertures (RS274X) option. Most modern photoplotters are raster plotters 
which can accept any size aperture. Generally, they also accept Gerber files with embedded apertures. 
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If embedded apertures are not used, a separate aperture file (*.apt) should be included with the 
Gerber files, when sent to the manufacturer. 

 

A special aperture must be provided for any file when holes are defined for any Pads or Vias in the 
PCB file. This is because the PCB Editor needs to provide an aperture for stroking Drill Drawing 
symbols and/or text. The aperture is required even if you are not generating a Drill Drawing plot. If no 
holes are in the file (no vias, all pad holes defined as zero, for example), the aperture is not required. 

 

When you use an existing aperture file, the PCB Editor scans the primitives (tracks, pads, etc) in the 
PCB document and matches these with aperture descriptions in the loaded *.apt file. If there is no 
exact match of aperture to primitive, the PCB Editor will automatically "paint" the primitive with a 
suitable smaller aperture. If there is no aperture suitable to "paint" with, a *.MAT (match) file will be 
generated listing the missing apertures and Gerber file generation will be aborted.  

 

If using automatic aperture generation the required apertures for Drill Drawing symbols and other text 
is automatically provided with the stroke width being proportional to the text height. For example, the 
default 50 mil Drill Drawing symbol size yields a 7 mil aperture for stroking the symbols. 60 mil text 
height yields 8 mils stroke width. You should take care in defining text sizes for Silkscreen (or Overlay) 
layers, as very fine strokes may not be successfully screened onto the board. 

 

The Gerber file extension naming convention conforms to general industry practice. 

 

Check with your manufacturer to see if they can accept PCB files directly. Many manufacturers will be 
able to produce a PCB directly from a binary PCB file. 

 

Contact your photoplot bureau before generating any photoplots. Matching available plotting options at 
the edit level can save considerable time and expense when generating Gerber phototools. 

 

The output path for generated files is set in the Options tab of the Options for Project dialog. By 
default, the output path is set to a sub-folder under the folder that contains the Project file and has the 
name: Project Outputs for ProjectName. The output path can be changed as required. If the option to 
use a separate folder for each output type has been enabled in the Options tab, then the Gerber files 
will be written to a further sub-folder, named: Gerber Output. 

 

When generated, the output will be added to the project and appear in the Projects panel under the 
Generated folder, in an appropriately-named sub-folder. If you have used a separate folder for each 
output type, then corresponding (separate) Generated folders will be added to the Projects panel 
(e.g. Generated (Gerber Output)). 
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Revision History 

Date Version No. Revision

05-Dec-2005 1.0 New release 

12-Apr-2007 1.1 Updated for Altium Designer 6.7 

Software, hardware, documentation and related materials:  

Copyright © 2007 Altium Limited. 

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use 
only and will not be copied or posted on any network computer or broadcast in any media, and (2) no modifications 
of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium, Altium Designer, Board Insight, Design Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, 
P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their respective logos are trademarks or 
registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks 
referenced herein are the property of their respective owners and no trademark rights to the same are claimed. 
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