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1 Introduction

This tutorial explains how to use the SignalTap II feature within Altera’s Quartus ® II software. The SignalTap II
Embedded Logic Analyzer is a system-level debugging tool that captures and displays signals in circuits designed
for implementation in Altera’s FPGAs.

Contents:

* Example Circuit

» Using the SignalTap II Logic Analyzer
* Probing the Design Using SignalTap

* Advanced Trigger Options

» Sample Depth and Buffer Acquisition Modes
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2 Background

Quartus® II software includes a system level debugging tool called SignalTap II that can be used to capture and
display signals in real time in any FPGA design.

Doing this tutorial, the reader will learn about:

* Probing signals using the SignalTap software

 Setting up triggers to specify when data is to be captured

This tutorial is aimed at the reader who wishes to probe signals in circuits defined using the Verilog hardware
description language. An equivalent tutorial is available for the reader who prefers the VHDL language.

The reader is expected to have access to a computer that has Quartus II software installed. The detailed examples in
the tutorial were obtained using the Quartus II version 9.1, but other versions of the software can also be used.

Note: Please note that there are no red LEDs on a DEO board. All procedures using red LEDs in this tutorial
are to be completed on the DEO board using green LEDs instead. If you are doing this tutorial on a DEO board,
replace LEDR with LEDG in the Verilog modules below.

3 Example Circuit

As an example, we will use the switch circuit implemented in Verilog in Figure 1. This circuit simply connects the
first 8 switches on the DE-series board to the first 8 red LEDs on the board. It does so at the positive edge of the
clock (CLOCK_50) by loading the values of the switches into a register whose output is connected directly to the
red LEDs.

// Top-level module

module switches (SW, CLOCK_50, LEDR);
input [7:0] SW;
input CLOCK_50;
output reg [7:0] LEDR;

always @(posedge CLOCK_50)

LEDR [7:0] <= SW [7:0];
endmodule

Figure 1. The switch circuit implemented in Verilog code

Implement this circuit as follows:
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* Create a project switches.

* Include a file switches.v, which corresponds to Figure 1, in the project.

¢ Select the correct device that is associated with the DE-series board. A list of device names for DE-series

boards can be found in Table 1.

* Import the relevant gsf file. For example, for a DE2 board, this file is called DE2_pin_assignments.qsf and can
be imported by clicking Assignments->Import Assignments. For convenience, this file is provided in the
design_files subdirectory within the tutorials folder, which is included on the CD-ROM that accompanies the
DE-series board and can also be found on Altera’s DE-series web pages. The node names used in the sample

circuit correspond to the names used in this file.

* Compile the design.

Board

Device Name

DEO

Cyclone IIT EP3C16F484C6

DE1

Cyclone II EP2C20F484C7

DE2

Cyclone II EP2C35F672C6

DE2-70

Cyclone II EP2C70F896C6

DE2-115

Cyclone IVE EP4CE115F29C7

Table 1. DE-series FPGA device names

4 Using the SignalTap Il software

In the first part of the tutorial, we are going to set up the SignalTap Logic Analyzer to probe the values of the 8 LED
switches. We will also set up the circuit to trigger when the first switch (LEDI[0]) is high.

1. Open the SignalTap II window by selecting File > New, which gives the window shown in Figure 2. Choose

SignalTap Il Logic Analyzer File and click OK.
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SOPC Builder System ~

—|- Design Filez
AHDL File
Block Diagran/S chematic File
EDIF File
State Machine Filz
Systemt'erilog HOL File
Tel Seript File
Werilog HDL File
WHDL File

=I- Memary Files
Hexadecimal [Intel-Farmat] File
Memary [nitialization File

= Verification/Debugging Files
In-System Sources and Probes File
Logic Analyzer | nterface File
SignalT ap |l Logic Analyzer File
Wector Waveform File

—|- Other Files
AHDL Include File
Block Symbol File
Chain Description File
Synopsys Design Congtraints File
Teut File

v

Cancel

Figure 2. Need to prepare a new file.

2. The SignalTap IT window with the Setup tab selected is depicted in Figure 3. Save the file under the name
switches.stp. In the dialog box that follows (Figure 4), click OK. For the dialog "Do you want to enable
SignalTap II file switches.stp’ for the current project?" click Yes (Figure 5). The file switches.stp is now the
SignalTap file associated with the project.

Note: If you want to disable this file from the project, or to disable SignalTap from the project, go to As-
signments > Settings. In the category list, select SignalTap Il Logic Analyzer, bringing up the window
in Figure 6. To turn off the analyzer, uncheck Enable SignalTap Il Logic Analyzer. Also, it is possible
to have multiple SignalTap files for a given project, but only one of them can be enabled at a time. Having
multiple SignalTap files might be useful if the project is very large and different sections of the project need
to be probed. To create a new SignalTap file for a project, simply follow Steps 1 and 2 again and give the new
file a different name. To change the SignalTap file associated with the project, in the SignalTap Il File name
box browse for the file wanted, click Open, and then click OK. For this tutorial we want to leave SignalTap
enabled and we want the SignalTap II File name to be switches.stp. Make sure this is the case and click OK to
leave the settings window.
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B Quartus I - D:/switches/switches - switches - [stp1.stp]

Fil= Edit V“iew Project Processing Tools  ‘Window

Instance Manager:

|nstance ‘ Status

= Invalid JTAG configuration | =l

Invalid JTAG configuration

@ ¥ | JTAG Chain Configuration: _ @ b4

| LEs 0] Memary: 0| M5 |

IE auto_zighaltap_0 Mot running

0 cells 0 bitz Hardware:

j Setup...

Device: |

= ﬂ SOF Manager: D

J Scan Chain

< L4
auto_signattap_0 ‘é\AHOW all changes j Signal Configuration:
Hode Data Enable | Trigger Enable [Trigger Conditions Clack:
Type |Alias | Hame 0 0 1 | Basic ]
Data

Double-click to add nodes

A Data 2 Setup

Hierarchy Display:

: auta_signaltap_0

For Help, press FL

Sample depth: (128 «| FAM type:

o -

[™ Segmented: |

Storage qualifier

Type: E2 Continuous -
Input port: J

-
-

X [ Datalog [l
IE‘ auto_signaltap_0

|

Figure 3. The SignalTap II window.

.
- | ) Input "Data and Trigger” is empty

Figure 4. Click OK to this dialog.

1] E Do you want to enable SignalTap 1T File "switches. skp" Far the current project?
L

Yes Mo | Canicel |

Figure 5. Click Yes to this dialog.
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Settings - switches rz|
Category:
General SignalT ap |l Logic Analyzer
Files
Librariez Specify compilation options for the SignalT ap || Logic Analyzer.
Device
+ Dpera.tln.g Settings and E.ondltlons [v Enable SignalTap |l Logic Analyzer
+-- Compilation Process Seftings .
+- EDA Tool Settings SignalTap Il File name: | switches.stp
+- Analyzis & Synthesiz Settings

Fitter Settings
Timirg Analyzis Settings
Timeluest Timing Analyzer
+/- Clagszic Timing Analyzer Settings
Agsembler
Dresign Azsigtant

SignalT ap |l Logic &nalyze:
Logic Analyzer Interface
—|- Simulator Settings
Simulation Yerification

Simulation Qutput Files
PowerPlay Power Analyzer Settings
55N Analyzer

(] 8 | Cancel

Figure 6. The SignalTap II Settings window.

3. We now need to add the nodes in the project that we wish to probe. In the Setup tab of the SignalTap II
window, double-click in the area labeled Double-click to add nodes, bringing up the Node Finder window,
as shown in Figure 7. For the Filter field, select SignalTap II: pre-synthesis. Click List. This will now
display all the nodes that can be probed in the project. Highlight SW[0] to SW[7], and then click the > button
to add the switches to be probed. Then click OK.
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j Filter: | SignalTap Il pre-sprthesis j Custamize | List | Q ok |
jJ ¥ Include subentities | Cancel |
MNodes Found: Selected Nodes:

Marme Aszignments | A | M arne Assignments | Ty
<@ LEDR[3]~regd Unassigned I [switches]Sw[0] FIN_N25 Inp
¥ LEDR[4] FIN_ADZ22 = |switches|Sw1] FIN_MN26 Inp
@ LEDR[4]~regd Unassigned I [zwitchesSW (2] FIN_F25 Inp
& LEDR[G| PIN_ADZ3 B> lswitchesiS W3] PIN_SE14  Inp
«F LEDR[S]"regl Unassigned B |zmitches|Sw4] FIM_AF14 Inp
& LEDR[E] PIN_AD 21 B lswitchesiSW(E] PIN_AD12  Inp
& LEDR[E|"real Unassigned B> [switcheslSWIE] FIN_ACIZ  Inp
& LEDR7] PIN_AC21 B lswitchesiS W7 PIN_C13 Inp
@ LEDR[7] regl Unassigned i
5w Unassighed

<
=50 FIN_M25 J
5wl PIN_NZE @
52 PIN_P25 J
503 PIN_AET4
B E[4] PIN_4F14
B~ 5/[5] PIN_AD13
- 5] PIN_ACT3
= ST FIN_C13 i
< ¥ < ¥

Figure 7. Adding nodes in the Node Finder window on a DE-series board.

4. Before the SignalTap analyzer can work, we need to specify what clock is going to run the SignalTap module
that will be instantiated within our design. To do this, in the Clock box of the Signal Configuration pane of the
SignalTap window, click ..., which will again bring up the Node Finder window. Select List to display all the
nodes that can be added as the clock, and then double-click CLOCK_50, which results in the image shown in
Figure 11. Click OK.

j Filter: | SignalTap II: pre-syrthesis ﬂ Custamize.. | List | Q ak. |
jJ W Include subentities | Cancel |

Nodes Found: Selected Nodes:
| M ame Azsignments | & | EE) Azzignments | Typ
= CLOCK_50 PIN_M2 I |switchesICLOCK_S0 PIN_N2 Inp
T¥LEDR Unassigned
¥ LEDR[D] PIN_&E23
<« LEDR[0]"reqd Unassigned
¥ LEDR[1] PIN_&FZ3
4 LEDR[1]™reql Unassigned
S LEDR[Z] PIN_4E21
< LEDR[2]"regd Unassigned
L LEDR[3] PIN_AC22 ﬂ
<@ LEDR[3]~regd Urnassigned
¥ LEDR[4] PIN_&D22 A
@ LEDR[4] reqd Unassighed ﬁ
¥ LEDR[E] PIN_AD23
4 LEDR[G]™reql Unassigned
¥ LEDRI[E] PIN_ADZ
< LEDR[B]~regd Unassigned
¥ LEDR[7] PIN_AC21
<@ LEDR[7]~regd Urnassigned
Ll Hinaesionad 2

> < »

Figure 8. Setting CLOCK_50 as the clock for the SignalTap instance on a DE-series board.
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5. With the Setup tab of the SignalTap window selected, select the checkbox in the Trigger Conditions column.
In the dropdown menu at the top of this column, select Basic. Right-click on the Trigger Conditions cell
corresponding to the node SW[0] and select High. Now, the trigger for running the Logic Analyzer will be
when the first switch on the DE-series board is set to high, as shown in Figure 9. Note that you can right click
on the Trigger Conditions cell of any of the nodes being probed and select the trigger condition from a number
of choices. The actual trigger condition will be true when the logical AND of all these conditions is satisfied.
For now, just keep the trigger condition as SW[0] set to high and the others set to their default value, Don’t
Care.

auta_signattap_0 |é\Allow all changes ﬂ
Hode Data Enable | Trigger Enable |Trigger Conditions
Type |Alias Hame 8 8 1 | Basic -
= A0 v ~ T
[T S 4 ~ ]
[ 2] v ~ b
[T 53] 4 ~ ]
[ A4 v ~ b
[T SWIS] 4 ~ ]
[ ] SWE] ~ I 2
[T ST 4 ~ ]

Figure 9. Setting the trigger conditions.

6. For SignalTap II to work, we need to properly set up the hardware. First, make sure the DE-series board is
plugged in and turned on. In the Hardware section of the SignalTap II window, located in the top right corner,
click Setup, bringing up the window in Figure 10. Double click USB-Blaster in the Available Hardware Items
menu, then click Close.

Hardware Setup &‘
Hardware Settings ] JTAG Settings I

Select a programming hardware setup to use when programming devices. This programming

hardware zetup applies only ta the current programmer window

Currently selected hardware:

Available hardware items:

Hardware Server | Port | Add Hardware...
LI5B-Blaster Local UsE-0

Figure 10. Setting up hardware.

7. The last step in instantiating SignalTap in your design is to compile the design. In the main Quartus II window,
select Processing > Start Compilation and indicate that you want to save the changes to the file by clicking
Yes. After compilation, go to Tools > Programmer and load the project onto the DE-series board.
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5 Probing the Design Using SignalTap I

Now that the project with SignalTap II instantiated has been loaded onto the DE-series board, we can probe the

nodes as we would with an external logic analyzer.

1. On the DE-series board, first set all of the switches (0-7) to low. We will try to probe the values of these

switches once switch 0 becomes high.

2. In the SignalTap window, select Processing > Run Analysis or click the
tab of the SignalTap II Window. You should get a screen similar to Figure 11. Note that the status column
of the SignalTap II Instance Manager pane says "Waiting for trigger." This is because the trigger condition
(Switch 0 being high) has not yet been met. (This is of course if Switch 0 is actually low as instructed in the

g

previous step. If it is not, set it to low and then click Run Analysis again).

Instance Manager:

Instance

| Status | LEs: 468 | Memory: 1024 |

| | |Acquisiti0n in progress @ X | JTAG Chain Configuration: UTAG ready @

|£| auto_signaltap_0

\Waiting for trigger 468 cells 1024 bits Hardware: | J |

Device: | J

< 3 ﬂ S0OF Manager: J
log: 2010009021 13:10:35 #0 click to insert time bar
Type [Aias me [0 o TP W m oW e e oW w o wmW mTmoim
= SW[D] Acouistion in progress
[ 1]
» sM2)
[ T3]
[ 4]
» SIMIE]
[ SIME]
> A7)
[® Data | Setup
Higrarchy Display: X |- x
[ ® switches 2

Ii‘ auto_signaltap_0

Figure 11. SignalTap II window on a DE-series board after Run Analysis has been clicked.

3. Now, to observe the trigger feature of the Logic Analyzer, set Switch 0 on the DE-series board to high. The
data window of the SignalTap II window should display the image in Figure 12. Note that this window shows
the data levels of the 8 nodes being tapped before the trigger condition was met and also after. To see this, flip
on any of the switches from 0-7 and then click Run Analysis again. When switch 0 is set to high again, you

will see the values of the switches displayed on the SignalTap II Logic Analyzer.
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6

i Quartus Il - D:/switches/switches - switches - [switches.stp*]

J|For Help, press F1

File Edit BYEEN Project  Processing  Tools  wWindow
B ra o n E| @ s
Instance Manager; ’Q e |Fieeu:|}I to acquire X | JTAG Chain Configuration: TAG ready @ x
Instance | Status | LEs: 468 | emory: 1024 | ME12
|£| auto_signaltap 0 Mot mnning 468 cellz 1024 hits Hardware: | LISB-Blaster [USE-0] j Selup... |
Device: | (&1: EP2C35 (002084000 j Scan Chain
< ﬂ 50F Manager: | J
log: 2010009021 15:38:10 #0 click to insert time bar
Type |Alias | Hame S ot oce I s hssnen oo s s Dasan D s s s s
> :SA0) |
I A1) :
> 3N2]
I ST
I 4]
> SN3]
I SIME]
> SN7]
& Data B Setup
Hierarchy Dizplay: X [ Datalog @l =
* switches Ii‘ auto_signaltap_0
Ii‘ auta_gignaltap_0

Figure 12. Graphical display of values after trigger condition is met.

Advanced Trigger Options

Sometimes in a design you may want to have a more complicated triggering condition than SignalTap’s basic trig-
gering controls allow. The following section describes how to have multiple trigger levels as well as how to create
advanced triggering options.

6.1

Multiple Trigger Levels

In this section, we will set up the analyzer to trigger when there is a positive edge from switch 0, switch 1, switch 2,
and then switch 3, in that order.

10

1. Click the Setup tab of the SignalTap IT window.

2. In the Signal Configuration pane, select 4 from Trigger Conditions dropdown menu as in Figure 13 (you may
have to scroll down in the Signal Configuration pane to see this menu). This modifies the node list window by

creating three new Trigger Conditions columns.
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Trigger
Trigger flow contral: |Sequential j
Trigger position; |*iﬁ Pre: trigger position j
Tiggercondios: .
[~ Triggerin
Source: | J
Patterr: | J
[~ Trigger cut
Target: | J
Lewel: | J

Latency delay: |5 cycles

Figure 13. Set trigger levels to 4.

3. Right click the Trigger Condition 1 cell for SW[0], and select Rising Edge. Do the same for the Trigger
Condition 2 cell for SW[1], Trigger Condition 3 for SW[2], and Trigger Condition 4 for SW[3]. You should
end up with a window that looks like Figure 14.

trigger: 2010/09/21 15:37:02 #1 | 2 &llow all changes =]
Hode Data Enable | Trigger Enable Trigger Conditions

Type |Alias Hame 8 8 1% | Basic j|2|7| Basic j|3|7| Basic j|4|7| Basic |
[ ~ 1 i # b S

= 2 ~ 2 S e 2

[ W ¥ £ A iy

» O T~
= 2 ~ 2 EiE e 2

- V¥ ¥ &2 &2 g2 2

= 2 ~ 2 EiE e 2

= 2 ~ 2 EiE e 2

Figure 14. Multiple trigger levels set.

4. Now, recompile the design and load it onto the DE-series board again.

5. Go back to the SignalTap IT window, click on the Data tab, and then click Processing > Run Analysis. Note
that the window will say "Waiting for trigger" until the appropriate trigger condition is met. Then, in sequence,
flip to high switches 0, 1, 2, and then 3.

After this has been done, you will see the values of all the switches displayed as in Figure 15. Experiment by
following the procedure outlined in this section to set up other trigger conditions and use the DE-series board
to test these trigger conditions.

If you want to continuously probe the analyzer, instead of clicking "Run Analysis," click "Autorun Analysis"
which is the icon right next to the "Run Analysis" icon. If you do this, every time the trigger condition is met
the value in the display will be updated. You do not have to re-select "Run Analysis." To stop the "Autorun

. . . n .
Analysis" function, click the icon.
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log: 2010/0921 14:11:10 #0 click to insert time bar
Alias Hame -12 -8 -4 1] f} g 1 I2 1 P 2|D 24 28 32 36 40 44 45

g

S A S o)

Figure 15. Logic Analyzer display when all four trigger conditions have been met.

6.2 Advanced Trigger Conditions

In this section we will learn how to create advanced trigger conditions. Our trigger condition will be whenever any
one of the first 3 LED displays have a positive or negative edge. This means that the Logic Analyzer will update
its display everytime one of these inputs changes. Note that we could have any logical function of the nodes being
probed to trigger the analyzer. This is just an example. After you implement this in the next few steps, experiment
with your own advanced triggers.

1. Have the switches project opened and compiled from the previous examples in this tutorial.

2. Open the SignalTap window and select the Setup tab. In the Signal Configuration pane make sure that the
number of Trigger Conditions is set to 1.

3. In the Trigger Conditions column of the node list, make sure the box is checked and select Advanced from
the dropdown menu as in Figure 16. This will immediately bring up the window in Figure 17. This window
allows you to create a logic circuit using the various nodes that you are probing with SignalTap.

trigger: 2010/09:21 14:07:56 #0 | 2 &llow all charges |
Hode Data Enable | Trigger Enable |Trigger Conditions

Type | Alias Hame 8 8 17 | advanced _~|

3 0] I3 ~ i |

[ SW1] I3 I3

] SWn2] 2 2 2

- SW3] I3 I3 B

- SW4] I3 I3 B

m SWE] V V B

- SWE] I3 I3 B

- ST I3 I3 B

Figure 16. Select Advanced from the Trigger Level dropdown menu.
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Mode List:

1 Advanced Trigger Condition E ditor: Condition 1

Alias Hame

SA1]

CH AT

Object
E J

F-{- F-F-E-

»
»
»
»
»
»

Library:

Edge & Level Detector
Input Objects
Comparizon Operators
Bitwize Operators
Logical Operators
Feduction Operators
Shift Dperators

Result:

Object has an incomect number of inputs. W

< >

[®] Data |FZ Setup B Advanced Trigger 1

Figure 17. The Advanced Trigger editing window.

4. In the node list section of this window, highlight the 3 nodes SW[0] to SW[2], and click and drag them into
the white space of the Advanced trigger window, resulting in Figure 18. Note that you can also drag and drop
each node individually.

Mode List: A | Advanced Trigger Condition E ditar: Condition 1
Type |Alias Hame | Result: ~
> Sn0) SW[2]

[ SW[1] SWI[1]

> 2] SW[O0]

> 3]

[ 4] v Swi] =

Object Library: Si1] g— E Result '

# Edge & Level Detector

+- @ |nput Objects SHE 5

+- @ Comparizon Operators

+- 3 Bitwise Operatars

+-# Logical Operators

- He.ductlon Dperatars Object has an incomect number of inputs. .
+--# Shift Operators

< ¥

B Data |Fd Setup & Advanced Trigger 1

Figure 18. The three input nodes of interest dragged into the Advanced Trigger Editing Window.

5. We now need to add the necessary logical operators to our circuit. We will need an OR gate as well as three
edge level detectors. To access the OR gate, click on the plus sign next to Logical Operators and select
Logical Or, as in Figure 19. Then drag and drop the operator into the editing window.
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Object Library:

= Logical Dperators
# Logical Mot
# Logical And

E B | ogical Or

# Logical Xor
+-# Reduction Operators
+- W Shift Operators

Figure 19. Select the Logical Or operator from the Object Library window and drag this into the editing window.

6. In the object library click Edge and Level Detector and drag this into the editing window. Do this three
times and then arrange the circuit as in Figure 20. The three inputs should each be connected to the input of
an edge and level detector and the output of each of these detectors should be connected to the OR gate. The

output of the OR gate should be connected to the output pin already in the editing window.

3

Mode List: Advanced Trigger Condition Editar: Condition 1
Type |Alias Hame Result: ELD({sW[0] }) | |[ELD({8W[1] }) | |ELD{{8W[Z] }])
I 0]
> SW1] B detector 0
» SW2] L‘ I|
¢ t
= [ s o ge o
= Shl] EDGE & LEVEL
> SWS] DETECTOR
= Sl [l detector_1 B logical 0
etector_ ogical |
[ g SV 2 ] Ldata[n]
. P . data(] result result
# Edaoe & Level Detectar data[0]
+-- @ |nput Objects EDGE & LEVEL LOGICAL OR
+-- @ Comparizon Dperators DETECTOR
+-- @ Bitwize Operators ﬁ
+- @ Logical Operators |E| BRI ]
+- F!e.duc:tion Operatars datal] reault
+-- @ Shift Operators

14

<
& Data | Setup ] Advanced Trigger 1

EDGE & LEVEL

DETECTOR

Figure 20. Arrange the elements to create a circuit that looks like this.

7. We now need to set each edge and level detector to sense either a falling edge or a rising edge. Double click
one of the edge and level detectors, bringing up the window in Figure 21. Type E in the setting box and then
click OK. This will mean that the detector will output 1 whenever there is either a falling edge or a rising edge

of its input. Repeat this step for the two remaining edge and level detectors.
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o Object Properties gl
General Parameters l

Parameter

Hame: Edge & Level Detectar Pattem m
Feset Al
Setting: j
™

Description: |Specifies the pattern used to compare with inputs.
Create patterns uzing the following legal characters;
1=High, O=Low, H=High, L=Low. R=Rizing Edge.
F=Falling Edge, E=Either Edge, :<=Don't Care.

Ewxisting parameter settings:

M ame | Setting | Configurable at Runtime
Edge % Level Detector Pattern E Always
Fipeline 1] Mewver
ok | Cancel |

Figure 21. Type E in the setting box so that the function triggers on both rising and falling edges.

8. To test this Advanced trigger condition, compile the designed circuit again and load it onto the DE-series
board. Then run Signal Tap as described in the previous section. You should note that the Analyzer should
sense every time you change one of the first three switches on the board.

7 Sample Depth and Buffer Acquisition Modes

In this section, we will learn how to set the Sample Depth of our analyzer and about the two buffer acquisition
modes. To do this, we will use the previous project and use segmented buffering. Segmented buffering allows us to
divide the acquisition buffer into a number of separate, evenly sized segments. We will create a sample depth of 256
bits and divide this into eight 32-sample segments. This will allow us to capture 8 distinct events that occur around
the time of our trigger.

1. Change the trigger condition back to Basic and have only one trigger level. Make the trigger condition to be
at either edge of SW[O0].

2. In the Signal Configuration pane of the SignalTap II window, in the Sample depth dropdown menu of the
Data pane select 256. This option allows you to specify how many samples will be taken around the triggers in
your design. If you require many samples to debug your design, select a larger sample depth. Note, however,
that if the sample depth selected is too large, there might not be enough room on the board to hold your design
and the design will not compile. If this happens, try reducing the sample depth.

3. In the Signal Configuration pane of the SignalTap II window, in the Data section of the pane check Seg-
mented. In the dropdown menu beside Segmented, select 8 32 sample segments. This will result in a pane
that looks like Figure 22.
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Signal Configuration: x
Clock: [CLOCK_50 . A
Data

Sample depth: | 266 | RAM type

v Segmented:

Storage qualifier

Type: | J
Input port: J

-
-

Trigger

Trigger flow contral: |Sequential

Trigger position: |5ﬁ Pre trigger position

L Lef Lo

Trigger conditions: | 4

[~ Trigger in

Source: |

Patterr: |

[~ Trigger out

el | el
|

Target: |

-]

Figure 22. Select Segmented buffer acquisition mode with 8 32 sample segments.

4. Recompile and load the designed circuit onto the DE-series board. Now, we will be able to probe the design
using the Segmented Acquisition mode.

5. Go back to the SignalTap II window and click Processing > Run Analysis. Now, flip SW[0] up and down,
and in between flips change the values of the other 7 switches. After you have done this 8 times, the values
in the buffer will be displayed in the data window, and this will display the values that the 8 switches were at
around each trigger. A possible waveform is presented in Figure 23. This resulted from the user flipping up
one more switch between each flip of SW[0].
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Figure 23. Possible waveforms that could result when using the Segmented Acquisition mode.

7.1 Use of Synthesis Keep Directive

Sometimes a design you create will have wires in it that the Quartus compiler will optimize away. A very simple

example is the Verilog code below:

module threelnputAnd(SW, LEDR, CLOCK_50);
input CLOCK_50;
input [2:0] SW;

output reg [0:0] LEDR;

wire ab, abc /*synthesis keep*/;

assign ab=SW[0]&SW[1];
assign abc=ab&SW[2];

always @ (posedge CLOCK_50)

begin

LEDR[0O]<=abc;

end
endmodule

Figure 24. Using the Synthesis Keep directive in Quartus II.

A diagram of this circuit is shown in Figure 25. The triangular symbols labeled ab and abc are buffers inserted by

Quartus. They do not modify the signals passing through them.
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Figure 25. The circuit implemented by the code in Figure 24

We wish to instantiate a SignalTap II module that will probe the values of the inputs SW[2:0] and the outputs
LEDR[2:0]. We also want to probe the internal wire ab. However, normally when this Verilog code is compiled
(without the /*synthesis keep*/ directive), the wire ab is optimized away into one logic element, as in Figure 26.

LEDR[0]~reg0

SW[2..0] ahe h
o Al —» EDR[D.0]
EN&
CLOCK_50 >—‘ CLR

Figure 26. The same circuit without the Synthesis Keep directive.

If you wish to probe this internal wire, however, you will have to direct Quartus that you do not want this wire to
be optimized away. To do so, place the text /*synthesis keep*/ on the line that declares the wire, right before the
semicolon of the line. Figure 24 already contains this directive. We will now demonstrate how this wire can be
probed:

1. Create a new Quartus project threeInputAnd and copy the Verilog code from Figure 24. Compile the project.

2. Go to Tools > SignalTap Il Logic Analyzer, and then in the Setup pane of the SingalTap II window, right
click and choose Add Nodes.

3. For the Filter field, select SignalTap Il: pre-synthesis. Move the nodes ab, SW[0], SW[1], SW[2], and
LEDR[0] into the Selected Nodes list and then click OK.

4. In the Signal Configuration pane, select CLOCK_50 as the clock signal.
5. Set a Trigger Condition to trigger when ab becomes high.

6. Import the relevant pin assignment file for the DE-series board (or assign the pins manually, as described in
Section 7 of the Quartus II Introduction tutorials). For a DE2 board, this file is named DE2_pin_assignments.qsf

7. Compile the project again.
8. Go to Tools > Programmer and load the circuit onto the DE-series board.

9. Open the SignalTap window again, and select the Data tab. Set all the switches on the DE-series board to the
low position. Then, start the analysis by selecting Processing > Run Analysis.

10. Set the first two switches to the high position. The Trigger Condition should be satisfied.
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